diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-09-02 14:28:07 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-09-05 13:04:34 -0700 |
commit | a425609f8bddc22c74216b4d613492c25b0970c7 (patch) | |
tree | 6b70ab1d0c2c0605b4f969ad93046623f7af1ff9 /meta-python/recipes-devtools/python/python-gevent.inc | |
parent | b6d967f052cc40887849a144e377cc7437e5bef6 (diff) | |
download | meta-openembedded-a425609f8bddc22c74216b4d613492c25b0970c7.tar.gz |
python3-gevent: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-gevent.inc')
-rw-r--r-- | meta-python/recipes-devtools/python/python-gevent.inc | 35 |
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-python/recipes-devtools/python/python-gevent.inc b/meta-python/recipes-devtools/python/python-gevent.inc deleted file mode 100644 index bc89d104af..0000000000 --- a/meta-python/recipes-devtools/python/python-gevent.inc +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | SUMMARY = "A coroutine-based Python networking library" | ||
2 | DESCRIPTION = "gevent is a coroutine-based Python networking library that uses greenlet to provide \ | ||
3 | a high-level synchronous API on top of the libevent event loop." | ||
4 | HOMEPAGE = "http://www.gevent.org" | ||
5 | LICENSE = "MIT & Python-2.0 & BSD" | ||
6 | LIC_FILES_CHKSUM = "file://LICENSE;md5=4de99aac27b470c29c6c309e0c279b65 \ | ||
7 | file://NOTICE;md5=18108df3583462cafd457f024b9b09b5 \ | ||
8 | file://deps/libev/LICENSE;md5=d6ad416afd040c90698edcdf1cbee347 \ | ||
9 | " | ||
10 | DEPENDS += "libevent" | ||
11 | DEPENDS += "${PYTHON_PN}-greenlet" | ||
12 | RDEPENDS_${PN} = "${PYTHON_PN}-greenlet \ | ||
13 | ${PYTHON_PN}-mime \ | ||
14 | ${PYTHON_PN}-pprint \ | ||
15 | " | ||
16 | |||
17 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-gevent:" | ||
18 | |||
19 | SRC_URI_append = " \ | ||
20 | file://libev-conf.patch;patch=1;pnum=1 \ | ||
21 | file://0002-setup.py-do-not-query-for-include-dir.patch \ | ||
22 | " | ||
23 | |||
24 | SRC_URI[md5sum] = "6b9dd98917061803d9158e5258b8f412" | ||
25 | SRC_URI[sha256sum] = "1eb7fa3b9bd9174dfe9c3b59b7a09b768ecd496debfc4976a9530a3e15c990d1" | ||
26 | |||
27 | # The python-gevent has no autoreconf ability | ||
28 | # and the logic for detecting a cross compile is flawed | ||
29 | # so always force a cross compile | ||
30 | do_configure_append() { | ||
31 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/libev/configure | ||
32 | sed -i -e 's/^cross_compiling=no/cross_compiling=yes/' ${S}/deps/c-ares/configure | ||
33 | } | ||
34 | |||
35 | inherit pypi | ||