diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-09-02 14:28:08 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-09-05 13:04:40 -0700 |
commit | aac74bcb8135a44514821551b1126946f2a30434 (patch) | |
tree | 5ead1d8b42b1481e398d6a7f26bd0ed3b4f980f6 /meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch | |
parent | a425609f8bddc22c74216b4d613492c25b0970c7 (diff) | |
download | meta-openembedded-aac74bcb8135a44514821551b1126946f2a30434.tar.gz |
python3-gevent: Upgrade 1.4.0 -> 20.6.2
Upgrade to release 20.6.2:
- It is now possible to build and use the embedded libuv on a
Cygwin platform.
- Bug fix: relax the version constraint for psutil on PyPy.
- The include directories used to compile the C extensions have
been tweaked with the intent of making it easier to use older
debug versions of Python.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch | 26 |
1 files changed, 0 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch b/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch deleted file mode 100644 index 7536b71a69..0000000000 --- a/meta-python/recipes-devtools/python/python-gevent/0002-setup.py-do-not-query-for-include-dir.patch +++ /dev/null | |||
@@ -1,26 +0,0 @@ | |||
1 | From a53ed6b2f967a5f95e69d51cad3f8c120d7df65b Mon Sep 17 00:00:00 2001 | ||
2 | From: Alexander Kanavin <alex.kanavin@gmail.com> | ||
3 | Date: Thu, 7 Feb 2019 15:21:15 +0100 | ||
4 | Subject: [PATCH] setup.py: do not query for include dir | ||
5 | |||
6 | As this will return the native python directory erroneously. | ||
7 | |||
8 | Upstream-Status: Inappropriate [oe-core specific] | ||
9 | Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> | ||
10 | --- | ||
11 | setup.py | 2 +- | ||
12 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 86d6c5a..5d22291 100755 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -52,7 +52,7 @@ from _setupares import ARES | ||
19 | # Get access to the greenlet header file. | ||
20 | # The sysconfig dir is not enough if we're in a virtualenv | ||
21 | # See https://github.com/pypa/pip/issues/4610 | ||
22 | -include_dirs = [sysconfig.get_path("include")] | ||
23 | +include_dirs = [] | ||
24 | venv_include_dir = os.path.join(sys.prefix, 'include', 'site', | ||
25 | 'python' + sysconfig.get_python_version()) | ||
26 | venv_include_dir = os.path.abspath(venv_include_dir) | ||