summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-12 18:12:28 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-13 14:07:47 -0800
commit115144fce9d97143bcb77ee4bdab5b19e61f6f82 (patch)
tree38c854368c417f720a33f65fa11d6927992a971c /meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
parent0b7e50f7be5d639250f05a694272977216e7f7dd (diff)
downloadmeta-openembedded-115144fce9d97143bcb77ee4bdab5b19e61f6f82.tar.gz
python3-grpcio: Upgrade to 1.27.1
Merge inc file into bb, there are no other users of it Delete gettid patch, fixed differenty upstream Add code to use cross compiler in setup.py Define GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY so it does not use SYS_clock_gettime syscalls since it does not work when 64bit time_t is used on 32bit arches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch40
1 files changed, 0 insertions, 40 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
deleted file mode 100644
index f17f048de8..0000000000
--- a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ /dev/null
@@ -1,40 +0,0 @@
1From b02be74a2eff8abc612ef84f30e0fbce6a7f65f5 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 4 Aug 2017 09:04:07 -0700
4Subject: [PATCH] setup.py: Do not mix C and C++ compiler options
5
6EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX
7so using -std=c++11 or -std=gnu99 together will cause
8build time errors espcially with clang
9
10error: invalid argument '-std=gnu99' not allowed with 'C++'
11
12gcc7 ( defaults are -std=gnu11 and -std=gnu++14 )
13 as well clang default to these standards mode or newer
14anyway
15
16Signed-off-by: Khem Raj <raj.khem@gmail.com>
17---
18 setup.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21--- a/setup.py
22+++ b/setup.py
23@@ -145,7 +145,7 @@ ENABLE_DOCUMENTATION_BUILD = os.environ.
24 EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None)
25 EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None)
26 if EXTRA_ENV_COMPILE_ARGS is None:
27- EXTRA_ENV_COMPILE_ARGS = ' -std=c++11'
28+ EXTRA_ENV_COMPILE_ARGS = ""
29 if 'win32' in sys.platform and sys.version_info < (3, 5):
30 EXTRA_ENV_COMPILE_ARGS += ' -D_hypot=hypot'
31 # We use define flags here and don't directly add to DEFINE_MACROS below to
32@@ -157,7 +157,7 @@ if EXTRA_ENV_COMPILE_ARGS is None:
33 else:
34 EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64'
35 elif "linux" in sys.platform:
36- EXTRA_ENV_COMPILE_ARGS += ' -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions'
37+ EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions'
38 elif "darwin" in sys.platform:
39 EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions'
40 EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_32BIT'