diff options
author | Jens Rehsack <sno@netbsd.org> | 2018-08-27 13:07:31 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-08-28 09:36:28 -0700 |
commit | b3b34496758768d06a18621754492dde730c9423 (patch) | |
tree | e3581d6353f5e60d670360b3b6dc529452fceb6d /meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |
parent | d9309e44aa1d530c77ced19af1b4d2c5c0dbec6e (diff) | |
download | meta-openembedded-b3b34496758768d06a18621754492dde730c9423.tar.gz |
python{,3}-grpcio: update to 1.14.1
Update python-grpcio and add related python3-grpcio recipe
for recent features and bug-fixes.
Signed-off-by: Jens Rehsack <sno@netbsd.org>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 21 |
1 files changed, 15 insertions, 6 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch index 0c1d964a61..996597b146 100644 --- a/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ b/meta-python/recipes-devtools/python/python-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -18,16 +18,25 @@ Signed-off-by: Khem Raj <raj.khem@gmail.com> | |||
18 | setup.py | 2 +- | 18 | setup.py | 2 +- |
19 | 1 file changed, 1 insertion(+), 1 deletion(-) | 19 | 1 file changed, 1 insertion(+), 1 deletion(-) |
20 | 20 | ||
21 | Index: grpcio-1.8.4/setup.py | 21 | Index: grpcio-1.14.1/setup.py |
22 | =================================================================== | 22 | =================================================================== |
23 | --- grpcio-1.8.4.orig/setup.py | 23 | --- grpcio-1.14.1.orig/setup.py |
24 | +++ grpcio-1.8.4/setup.py | 24 | +++ grpcio-1.14.1/setup.py |
25 | @@ -115,7 +115,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: | 25 | @@ -123,7 +123,7 @@ ENABLE_DOCUMENTATION_BUILD = os.environ. |
26 | EXTRA_ENV_COMPILE_ARGS = os.environ.get('GRPC_PYTHON_CFLAGS', None) | ||
27 | EXTRA_ENV_LINK_ARGS = os.environ.get('GRPC_PYTHON_LDFLAGS', None) | ||
28 | if EXTRA_ENV_COMPILE_ARGS is None: | ||
29 | - EXTRA_ENV_COMPILE_ARGS = ' -std=c++11' | ||
30 | + EXTRA_ENV_COMPILE_ARGS = "" | ||
31 | if 'win32' in sys.platform and sys.version_info < (3, 5): | ||
32 | EXTRA_ENV_COMPILE_ARGS += ' -D_hypot=hypot' | ||
33 | # We use define flags here and don't directly add to DEFINE_MACROS below to | ||
34 | @@ -135,7 +135,7 @@ if EXTRA_ENV_COMPILE_ARGS is None: | ||
26 | else: | 35 | else: |
27 | EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64' | 36 | EXTRA_ENV_COMPILE_ARGS += ' -D_ftime=_ftime64 -D_timeb=__timeb64' |
28 | elif "linux" in sys.platform: | 37 | elif "linux" in sys.platform: |
29 | - EXTRA_ENV_COMPILE_ARGS += ' -std=c++11 -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions' | 38 | - EXTRA_ENV_COMPILE_ARGS += ' -std=gnu99 -fvisibility=hidden -fno-wrapv -fno-exceptions' |
30 | + EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' | 39 | + EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' |
31 | elif "darwin" in sys.platform: | 40 | elif "darwin" in sys.platform: |
32 | EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' | 41 | EXTRA_ENV_COMPILE_ARGS += ' -fvisibility=hidden -fno-wrapv -fno-exceptions' |
33 | 42 | EXTRA_ENV_COMPILE_ARGS += ' -DPB_FIELD_16BIT' | |