summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio/gettid.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-12 18:12:28 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-13 14:07:47 -0800
commit115144fce9d97143bcb77ee4bdab5b19e61f6f82 (patch)
tree38c854368c417f720a33f65fa11d6927992a971c /meta-python/recipes-devtools/python/python-grpcio/gettid.patch
parent0b7e50f7be5d639250f05a694272977216e7f7dd (diff)
downloadmeta-openembedded-115144fce9d97143bcb77ee4bdab5b19e61f6f82.tar.gz
python3-grpcio: Upgrade to 1.27.1
Merge inc file into bb, there are no other users of it Delete gettid patch, fixed differenty upstream Add code to use cross compiler in setup.py Define GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY so it does not use SYS_clock_gettime syscalls since it does not work when 64bit time_t is used on 32bit arches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio/gettid.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio/gettid.patch26
1 files changed, 0 insertions, 26 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/gettid.patch b/meta-python/recipes-devtools/python/python-grpcio/gettid.patch
deleted file mode 100644
index fb15cf7f96..0000000000
--- a/meta-python/recipes-devtools/python/python-grpcio/gettid.patch
+++ /dev/null
@@ -1,26 +0,0 @@
1use glibc provided gettid API for glibc 2.30+
2
3glibc 2.30 introduced this function see [1]
4so it's best to detect it
5and provide fallback only if it's not present
6
7[1] https://sourceware.org/bugzilla/show_bug.cgi?id=6399
8
9Upstream-Status: Pending
10Signed-off-by: Khem Raj <raj.khem@gmail.com>
11--- a/src/core/lib/gpr/log_linux.cc
12+++ b/src/core/lib/gpr/log_linux.cc
13@@ -40,7 +40,13 @@
14 #include <time.h>
15 #include <unistd.h>
16
17+#if defined(__GLIBC__)
18+#if !__GLIBC_PREREQ(2,29)
19 static long gettid(void) { return syscall(__NR_gettid); }
20+#endif
21+#else
22+static long gettid(void) { return syscall(__NR_gettid); }
23+#endif
24
25 void gpr_log(const char* file, int line, gpr_log_severity severity,
26 const char* format, ...) {