summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2020-02-12 18:12:28 -0800
committerKhem Raj <raj.khem@gmail.com>2020-02-13 14:07:47 -0800
commit115144fce9d97143bcb77ee4bdab5b19e61f6f82 (patch)
tree38c854368c417f720a33f65fa11d6927992a971c /meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch
parent0b7e50f7be5d639250f05a694272977216e7f7dd (diff)
downloadmeta-openembedded-115144fce9d97143bcb77ee4bdab5b19e61f6f82.tar.gz
python3-grpcio: Upgrade to 1.27.1
Merge inc file into bb, there are no other users of it Delete gettid patch, fixed differenty upstream Add code to use cross compiler in setup.py Define GRPC_PYTHON_DISABLE_LIBC_COMPATIBILITY so it does not use SYS_clock_gettime syscalls since it does not work when 64bit time_t is used on 32bit arches Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch16
1 files changed, 0 insertions, 16 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch b/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch
deleted file mode 100644
index fef7d9e757..0000000000
--- a/meta-python/recipes-devtools/python/python-grpcio/riscv64_support.patch
+++ /dev/null
@@ -1,16 +0,0 @@
1Add RISC-V 64bit support
2
3Upstream-Status: Pending
4Signed-off-by: Khem Raj <raj.khem@gmail.com>
5--- a/third_party/boringssl/include/openssl/base.h
6+++ b/third_party/boringssl/include/openssl/base.h
7@@ -104,6 +104,9 @@ extern "C" {
8 #elif defined(__mips__) && defined(__LP64__)
9 #define OPENSSL_64_BIT
10 #define OPENSSL_MIPS64
11+#elif defined(__riscv) && defined(__riscv_xlen)
12+#define OPENSSL_64_BIT
13+#define OPENSSL_RISCV64
14 #elif defined(__pnacl__)
15 #define OPENSSL_32_BIT
16 #define OPENSSL_PNACL