summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
diff options
context:
space:
mode:
authorKrzysztof Kozlowski <krzk@kernel.org>2017-07-09 17:47:21 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2017-07-14 23:44:31 +0200
commitd0513b1d6137168a69f93c0eb84fbe77ccfd0145 (patch)
treefac41cf7369b81e0833111f6a491e27e70738285 /meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
parentc15782ebe5bf342d3328572c28d00788df9ea095 (diff)
downloadmeta-openembedded-d0513b1d6137168a69f93c0eb84fbe77ccfd0145.tar.gz
meta-python: Add Protobuf and gRPC Python recipes
Add recipes for Python PIP packages for Google's Protobuf, gRPC and gRPC tools. Signed-off-by: Krzysztof Kozlowski <krzk@kernel.org> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
new file mode 100644
index 0000000000..5412e02433
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.4.0.bb
@@ -0,0 +1,23 @@
1DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS = "python-protobuf"
6
7RDEPENDS_${PN} = "python-enum34 \
8 python-futures \
9 python-protobuf \
10 python-setuptools \
11 python-six \
12"
13
14LICENSE = "BSD-3-Clause"
15LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
16
17inherit pypi setuptools
18
19SRC_URI[md5sum] = "d882ae4eeef4f32ac9c1d32052bf05ad"
20SRC_URI[sha256sum] = "a3a213a4c24b5c572b386d752e3b74a3f1b8fa5d03c07b6166fa39f3a6cdef34"
21
22# For usage in other recipies when compiling protobuf files (e.g. by grpcio-tools)
23BBCLASSEXTEND = "native"