summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-grpcio_1.8.2.bb
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2018-01-03 17:08:52 -0500
committerArmin Kuster <akuster808@gmail.com>2018-01-16 21:33:05 -0800
commit33e62def4fea47b516e394e667fd442a16a0a60c (patch)
treeff11432f0d5b2e4daa6469ac6f0e8083aee9b587 /meta-python/recipes-devtools/python/python-grpcio_1.8.2.bb
parentbf51fd5931fb0256999c5f2f7820bd052d081de6 (diff)
downloadmeta-openembedded-33e62def4fea47b516e394e667fd442a16a0a60c.tar.gz
python-grpcio: update to version 1.8.2
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-grpcio_1.8.2.bb')
-rw-r--r--meta-python/recipes-devtools/python/python-grpcio_1.8.2.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-grpcio_1.8.2.bb b/meta-python/recipes-devtools/python/python-grpcio_1.8.2.bb
new file mode 100644
index 0000000000..5b0724ed82
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-grpcio_1.8.2.bb
@@ -0,0 +1,25 @@
1DESCRIPTION = "Google gRPC"
2HOMEPAGE = "http://www.grpc.io/"
3SECTION = "devel/python"
4
5DEPENDS = "python-protobuf"
6
7SRC_URI_append_class-target = " file://0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch "
8
9RDEPENDS_${PN} = "python-enum34 \
10 python-futures \
11 python-protobuf \
12 python-setuptools \
13 python-six \
14"
15
16LICENSE = "BSD-3-Clause"
17LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/BSD-3-Clause;md5=550794465ba0ec5312d6919e203a55f9"
18
19inherit pypi setuptools
20
21SRC_URI[md5sum] = "4d4ce91b5a56d724227aa116f971402c"
22SRC_URI[sha256sum] = "1ea1336f0d1158c4e00e96a94df84b75f6bbff9816abb6cc68cbdc9442a9ac55"
23
24# For usage in other recipes when compiling protobuf files (e.g. by grpcio-tools)
25BBCLASSEXTEND = "native"