diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2023-05-24 09:52:35 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-24 07:23:54 -0700 |
commit | 07fad37c9818a9f365c1f82f6f1907cafdb1d1f6 (patch) | |
tree | 1870794108a077e2cf18f70ad2fc88680a1c7b0b /meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch | |
parent | 26397c2ea3fe904cc99cd767c9e2b1c5b3840321 (diff) | |
download | meta-openembedded-07fad37c9818a9f365c1f82f6f1907cafdb1d1f6.tar.gz |
meta-python: remove unused patches from python2 recipes
* python2 recipes were removed in:
https://git.openembedded.org/meta-openembedded/commit/?id=05d0c5eee319055816bbea8b9dd972f723f68019
but some of the unused patch files were left behind
* meta-python/recipes-devtools/python/python-pyrex/pyrex-fix-optimized-mode.patch:
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch
meta-python/recipes-devtools/python/python-imaging/fix-freetype-includes.patch
meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch
meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a
* meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch
meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch
meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch
https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a
* meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-numeric_24.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch | 65 |
1 files changed, 0 insertions, 65 deletions
diff --git a/meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch b/meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch deleted file mode 100644 index 4960ed4661..0000000000 --- a/meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch +++ /dev/null | |||
@@ -1,65 +0,0 @@ | |||
1 | At least lcms wasn't deterministicly detected from sysroot. | ||
2 | |||
3 | This will allow to export LCMS_ENABLED=False when lcms isn't in PACKAGECONFIG. | ||
4 | |||
5 | Upstream-Status: Inappropriate [configuration] | ||
6 | |||
7 | Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> | ||
8 | |||
9 | diff -uNr Imaging-1.1.7.orig/setup.py Imaging-1.1.7/setup.py | ||
10 | --- Imaging-1.1.7.orig/setup.py 2013-07-22 10:17:02.081457075 +0200 | ||
11 | +++ Imaging-1.1.7/setup.py 2013-07-22 13:10:09.029707492 +0200 | ||
12 | @@ -39,6 +39,12 @@ | ||
13 | TIFF_ROOT = None | ||
14 | FREETYPE_ROOT = os.environ['STAGING_LIBDIR'], os.environ['STAGING_INCDIR'] | ||
15 | LCMS_ROOT = None | ||
16 | +TCL_ENABLED = os.getenv('TCL_ENABLED', "True") | ||
17 | +JPEG_ENABLED = os.getenv('JPEG_ENABLED', "True") | ||
18 | +ZLIB_ENABLED = os.getenv('ZLIB_ENABLED', "True") | ||
19 | +TIFF_ENABLED = os.getenv('TIFF_ENABLED', "True") | ||
20 | +FREETYPE_ENABLED = os.getenv('FREETYPE_ENABLED', "True") | ||
21 | +LCMS_ENABLED = os.getenv('LCMS_ENABLED', "True") | ||
22 | |||
23 | # FIXME: add mechanism to explicitly *disable* the use of a library | ||
24 | |||
25 | @@ -220,22 +226,22 @@ | ||
26 | zlib = jpeg = tiff = freetype = tcl = tk = lcms = None | ||
27 | feature = feature() | ||
28 | |||
29 | - if find_include_file(self, "zlib.h"): | ||
30 | + if ZLIB_ENABLED == 'True' and find_include_file(self, "zlib.h"): | ||
31 | if find_library_file(self, "z"): | ||
32 | feature.zlib = "z" | ||
33 | elif sys.platform == "win32" and find_library_file(self, "zlib"): | ||
34 | feature.zlib = "zlib" # alternative name | ||
35 | |||
36 | - if find_include_file(self, "jpeglib.h"): | ||
37 | + if JPEG_ENABLED == 'True' and find_include_file(self, "jpeglib.h"): | ||
38 | if find_library_file(self, "jpeg"): | ||
39 | feature.jpeg = "jpeg" | ||
40 | elif sys.platform == "win32" and find_library_file(self, "libjpeg"): | ||
41 | feature.jpeg = "libjpeg" # alternative name | ||
42 | |||
43 | - if find_library_file(self, "tiff"): | ||
44 | + if TIFF_ENABLED == 'True' and find_library_file(self, "tiff"): | ||
45 | feature.tiff = "tiff" | ||
46 | |||
47 | - if find_library_file(self, "freetype"): | ||
48 | + if FREETYPE_ENABLED == 'True' and find_library_file(self, "freetype"): | ||
49 | # look for freetype2 include files | ||
50 | freetype_version = 0 | ||
51 | for dir in self.compiler.include_dirs: | ||
52 | @@ -256,11 +262,11 @@ | ||
53 | if dir: | ||
54 | add_directory(self.compiler.include_dirs, dir, 0) | ||
55 | |||
56 | - if find_include_file(self, "lcms.h"): | ||
57 | + if LCMS_ENABLED == 'True' and find_include_file(self, "lcms.h"): | ||
58 | if find_library_file(self, "lcms"): | ||
59 | feature.lcms = "lcms" | ||
60 | |||
61 | - if _tkinter and find_include_file(self, "tk.h"): | ||
62 | + if TCL_ENABLED == 'True' and _tkinter and find_include_file(self, "tk.h"): | ||
63 | # the library names may vary somewhat (e.g. tcl84 or tcl8.4) | ||
64 | version = TCL_VERSION[0] + TCL_VERSION[2] | ||
65 | if find_library_file(self, "tcl" + version): | ||