diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2023-05-24 09:52:35 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-24 07:23:54 -0700 |
commit | 07fad37c9818a9f365c1f82f6f1907cafdb1d1f6 (patch) | |
tree | 1870794108a077e2cf18f70ad2fc88680a1c7b0b /meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch | |
parent | 26397c2ea3fe904cc99cd767c9e2b1c5b3840321 (diff) | |
download | meta-openembedded-07fad37c9818a9f365c1f82f6f1907cafdb1d1f6.tar.gz |
meta-python: remove unused patches from python2 recipes
* python2 recipes were removed in:
https://git.openembedded.org/meta-openembedded/commit/?id=05d0c5eee319055816bbea8b9dd972f723f68019
but some of the unused patch files were left behind
* meta-python/recipes-devtools/python/python-pyrex/pyrex-fix-optimized-mode.patch:
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch
meta-python/recipes-devtools/python/python-imaging/fix-freetype-includes.patch
meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch
meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a
* meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch
meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch
meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch
https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a
* meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-numeric_24.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch | 38 |
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch b/meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch deleted file mode 100644 index b01136f9ac..0000000000 --- a/meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch +++ /dev/null | |||
@@ -1,38 +0,0 @@ | |||
1 | python-imaging: CVE-2016-2533 | ||
2 | |||
3 | the patch comes from: | ||
4 | https://web.nvd.nist.gov/view/vuln/detail?vulnId=CVE-2016-2533 | ||
5 | https://github.com/python-pillow/Pillow/commit/ae453aa18b66af54e7ff716f4ccb33adca60afd4#diff-8ff6909c159597e22288ad818938fd6b | ||
6 | |||
7 | PCD decoder overruns the shuffle buffer, Fixes #568 | ||
8 | |||
9 | Signed-off-by: Li Wang <li.wang@windriver.com> | ||
10 | --- | ||
11 | libImaging/PcdDecode.c | 4 ++-- | ||
12 | 1 file changed, 2 insertions(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/libImaging/PcdDecode.c b/libImaging/PcdDecode.c | ||
15 | index b6898e3..c02d005 100644 | ||
16 | --- a/libImaging/PcdDecode.c | ||
17 | +++ b/libImaging/PcdDecode.c | ||
18 | @@ -47,7 +47,7 @@ ImagingPcdDecode(Imaging im, ImagingCodecState state, UINT8* buf, int bytes) | ||
19 | out[0] = ptr[x]; | ||
20 | out[1] = ptr[(x+4*state->xsize)/2]; | ||
21 | out[2] = ptr[(x+5*state->xsize)/2]; | ||
22 | - out += 4; | ||
23 | + out += 3; | ||
24 | } | ||
25 | |||
26 | state->shuffle((UINT8*) im->image[state->y], | ||
27 | @@ -62,7 +62,7 @@ ImagingPcdDecode(Imaging im, ImagingCodecState state, UINT8* buf, int bytes) | ||
28 | out[0] = ptr[x+state->xsize]; | ||
29 | out[1] = ptr[(x+4*state->xsize)/2]; | ||
30 | out[2] = ptr[(x+5*state->xsize)/2]; | ||
31 | - out += 4; | ||
32 | + out += 3; | ||
33 | } | ||
34 | |||
35 | state->shuffle((UINT8*) im->image[state->y], | ||
36 | -- | ||
37 | 1.7.9.5 | ||
38 | |||