diff options
author | Martin Jansa <martin.jansa@gmail.com> | 2023-05-24 09:52:35 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-05-24 07:23:54 -0700 |
commit | 07fad37c9818a9f365c1f82f6f1907cafdb1d1f6 (patch) | |
tree | 1870794108a077e2cf18f70ad2fc88680a1c7b0b /meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch | |
parent | 26397c2ea3fe904cc99cd767c9e2b1c5b3840321 (diff) | |
download | meta-openembedded-07fad37c9818a9f365c1f82f6f1907cafdb1d1f6.tar.gz |
meta-python: remove unused patches from python2 recipes
* python2 recipes were removed in:
https://git.openembedded.org/meta-openembedded/commit/?id=05d0c5eee319055816bbea8b9dd972f723f68019
but some of the unused patch files were left behind
* meta-python/recipes-devtools/python/python-pyrex/pyrex-fix-optimized-mode.patch:
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch
meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch
meta-python/recipes-devtools/python/python-imaging/fix-freetype-includes.patch
meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch
meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a
* meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch
meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch
meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch
https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a
* meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
* meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-numeric_24.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch | 25 |
1 files changed, 0 insertions, 25 deletions
diff --git a/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch b/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch deleted file mode 100644 index 028a51ad59..0000000000 --- a/meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch +++ /dev/null | |||
@@ -1,25 +0,0 @@ | |||
1 | Avoid getting host sysroot paths in the library paths to fix issue like: | ||
2 | |||
3 | | /home/andrei/work/yocto/build-rpi-master/tmp/sysroots/x86_64-linux/usr/lib/libz.so: file not recognized: File format not recognized | ||
4 | |||
5 | Upstream-Status: Inappropriate [configuration] | ||
6 | |||
7 | Signed-off-by: Andrei Gherzan <andrei@gherzan.ro> | ||
8 | |||
9 | |||
10 | Index: Imaging-1.1.7/setup.py | ||
11 | =================================================================== | ||
12 | --- Imaging-1.1.7.orig/setup.py | ||
13 | +++ Imaging-1.1.7/setup.py | ||
14 | @@ -155,11 +155,6 @@ class pil_build_ext(build_ext): | ||
15 | |||
16 | # FIXME: check /opt/stuff directories here? | ||
17 | |||
18 | - prefix = sysconfig.get_config_var("prefix") | ||
19 | - if prefix: | ||
20 | - add_directory(library_dirs, os.path.join(prefix, "lib")) | ||
21 | - add_directory(include_dirs, os.path.join(prefix, "include")) | ||
22 | - | ||
23 | # | ||
24 | # locate tkinter libraries | ||
25 | |||