diff options
author | Mark Asselstine <mark.asselstine@windriver.com> | 2018-04-02 11:03:43 -0400 |
---|---|---|
committer | Armin Kuster <akuster808@gmail.com> | 2018-04-08 17:00:06 -0700 |
commit | 3aa3c374ca7cd0850bdede6a404936737abb4068 (patch) | |
tree | 4a2297b1eb31917c1fb747185aece9f511ef665d /meta-python/recipes-devtools/python/python-jsonpatch | |
parent | 3ab6741f949b7f256ee4145415d5055afa0e3064 (diff) | |
download | meta-openembedded-3aa3c374ca7cd0850bdede6a404936737abb4068.tar.gz |
python-jsonpatch: fix do_install failure with py2 build
The following error is seen when do_install is run
| UnicodeEncodeError: 'ascii' codec can't encode character u'\xf6' in
| position 16: ordinal not in range(128) ERROR: python setup.py
| install execution failed.
This is reported in the upstream project as part of pull request #81
https://github.com/stefankoegl/python-json-patch/pull/81
Since a release is not yet available with the required fix we must
apply the fix as a patch.
Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com>
Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-jsonpatch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch | 35 |
1 files changed, 35 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch b/meta-python/recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch new file mode 100644 index 0000000000..ccd8e127c9 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-jsonpatch/Drop-support-for-EOL-Python-3.3.patch | |||
@@ -0,0 +1,35 @@ | |||
1 | From 71bdeed8b49390ff14fe8f0434fc8a1038d89128 Mon Sep 17 00:00:00 2001 | ||
2 | From: Hugo <hugovk@users.noreply.github.com> | ||
3 | Date: Tue, 16 Jan 2018 14:22:33 +0200 | ||
4 | Subject: [PATCH 1/4] Drop support for EOL Python 3.3 | ||
5 | |||
6 | Upstream-Status: Backport | ||
7 | |||
8 | [MA: remove dev only files from patch] | ||
9 | Signed-off-by: Mark Asselstine <mark.asselstine@windriver.com> | ||
10 | |||
11 | --- | ||
12 | setup.py | 2 +- | ||
13 | |||
14 | diff --git a/setup.py b/setup.py | ||
15 | index 0776c41..471c433 100644 | ||
16 | --- a/setup.py | ||
17 | +++ b/setup.py | ||
18 | @@ -58,7 +58,6 @@ CLASSIFIERS = [ | ||
19 | 'Programming Language :: Python :: 2', | ||
20 | 'Programming Language :: Python :: 2.7', | ||
21 | 'Programming Language :: Python :: 3', | ||
22 | - 'Programming Language :: Python :: 3.3', | ||
23 | 'Programming Language :: Python :: 3.4', | ||
24 | 'Programming Language :: Python :: 3.5', | ||
25 | 'Programming Language :: Python :: 3.6', | ||
26 | @@ -81,5 +80,6 @@ setup(name=PACKAGE, | ||
27 | package_data={'': ['requirements.txt']}, | ||
28 | scripts=['bin/jsondiff', 'bin/jsonpatch'], | ||
29 | classifiers=CLASSIFIERS, | ||
30 | + python_requires='>=2.7, !=3.0.*, !=3.1.*, !=3.2.*, !=3.3.*', | ||
31 | **OPTIONS | ||
32 | ) | ||
33 | -- | ||
34 | 2.7.4 | ||
35 | |||