summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
diff options
context:
space:
mode:
authorJens Rehsack <sno@netbsd.org>2018-08-27 13:07:35 +0200
committerKhem Raj <raj.khem@gmail.com>2018-08-28 09:36:28 -0700
commit15bd5f4ebb70f3cfc36534a759ce2dbd6515d6e6 (patch)
tree267f9b3093ce0d3d7b6b8af4aa13338f7418627d /meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
parentb3b34496758768d06a18621754492dde730c9423 (diff)
downloadmeta-openembedded-15bd5f4ebb70f3cfc36534a759ce2dbd6515d6e6.tar.gz
python{, 3}-m2crypto: update from 0.26.4 -> 0.30.1
Updating recipe for crypto and SSL toolkit for python and support python3 infrastructure of Yocto as well as the already supported python2 line. Refresh patches to fix devtool warnings Signed-off-by: Jens Rehsack <sno@netbsd.org> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch44
1 files changed, 20 insertions, 24 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
index c71b16fece..b339d93f75 100644
--- a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
+++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch
@@ -10,30 +10,26 @@ Upstream-status: Unknown
10 setup.py | 6 +++--- 10 setup.py | 6 +++---
11 1 file changed, 3 insertions(+), 3 deletions(-) 11 1 file changed, 3 insertions(+), 3 deletions(-)
12 12
13diff --git a/setup.py b/setup.py 13Index: M2Crypto-0.30.1/setup.py
14index 3407c82..15ed7cd 100644 14===================================================================
15--- a/setup.py 15--- M2Crypto-0.30.1.orig/setup.py
16+++ b/setup.py 16+++ M2Crypto-0.30.1/setup.py
17@@ -127,7 +127,7 @@ class _M2CryptoBuildExt(build_ext.build_ext): 17@@ -130,6 +130,7 @@ class _M2CryptoBuildExt(build_ext.build_
18 self.openssl = os.path.join(self.openssl, 'OpenSSL') 18 self.set_undefined_options('build', ('bundledlls', 'bundledlls'))
19 else:
20 self.libraries = ['ssl', 'crypto']
21- self.openssl = '/usr'
22+ self.openssl = os.environ.get( "STAGING_DIR" )
23 19
24 def finalize_options(self): 20 self.libraries = ['ssl', 'crypto']
25 '''Overloaded build_ext implementation to append custom openssl 21+ self.openssl = os.environ.get( "STAGING_DIR" )
26@@ -143,8 +143,8 @@ class _M2CryptoBuildExt(build_ext.build_ext): 22 if sys.platform == 'win32':
27 if _openssl and os.path.isdir(_openssl): 23 self.libraries = ['ssleay32', 'libeay32']
28 self.openssl = _openssl 24 if self.openssl and openssl_version(self.openssl, 0x10100000, True):
25@@ -150,8 +151,8 @@ class _M2CryptoBuildExt(build_ext.build_
29 26
30- self.include_dirs.append(os.path.join(self.openssl, 'include')) 27 if self.openssl is not None:
31- openssl_library_dir = os.path.join(self.openssl, 'lib') 28 log.debug('self.openssl = %s', self.openssl)
32+ self.include_dirs.append(os.environ.get( "STAGING_INCDIR" )) 29- openssl_library_dir = os.path.join(self.openssl, 'lib')
33+ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" ) 30- openssl_include_dir = os.path.join(self.openssl, 'include')
31+ openssl_library_dir = os.environ.get( "STAGING_LIBDIR" )
32+ openssl_include_dir = os.environ.get( "STAGING_INCDIR" )
34 33
35 if platform.system() == "Linux": 34 self.library_dirs.append(openssl_library_dir)
36 if _multiarch: # on Fedora/RHEL it is an empty string 35 self.include_dirs.append(openssl_include_dir)
37--
382.7.4
39