diff options
author | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-22 13:34:41 +0200 |
---|---|---|
committer | Martin Jansa <Martin.Jansa@gmail.com> | 2014-07-30 12:49:45 +0200 |
commit | d22f4ca2e3e421615b601002061690a8f97257c0 (patch) | |
tree | 8cfee5bd859365868dc3cb5eb9ba91d9713efb79 /meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch | |
parent | 2d7c7956bd3655755e1e800b7b05732f0c1a3786 (diff) | |
download | meta-openembedded-d22f4ca2e3e421615b601002061690a8f97257c0.tar.gz |
meta-python: rename recipes-python to recipes-devtools
* match old structure from meta-oe
Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch | 39 |
1 files changed, 39 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch new file mode 100644 index 0000000000..bcbdf24bb5 --- /dev/null +++ b/meta-python/recipes-devtools/python/python-m2crypto/0001-setup.py-link-in-sysroot-not-in-host-directories.patch | |||
@@ -0,0 +1,39 @@ | |||
1 | From f11b9c71080513f9b867ba8f40613ba2ebc6e960 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Fri, 29 Mar 2013 15:17:17 +0100 | ||
4 | Subject: [PATCH] setup.py: link in sysroot, not in host directories | ||
5 | |||
6 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
7 | |||
8 | Upstream-status: Unknown | ||
9 | --- | ||
10 | setup.py | 6 +++--- | ||
11 | 1 file changed, 3 insertions(+), 3 deletions(-) | ||
12 | |||
13 | diff --git a/setup.py b/setup.py | ||
14 | index e7c49eb..8deaa34 100644 | ||
15 | --- a/setup.py | ||
16 | +++ b/setup.py | ||
17 | @@ -40,7 +40,7 @@ class _M2CryptoBuildExt(build_ext.build_ext): | ||
18 | self.openssl = 'c:\\pkg' | ||
19 | else: | ||
20 | self.libraries = ['ssl', 'crypto'] | ||
21 | - self.openssl = '/usr' | ||
22 | + self.openssl = os.environ.get( "STAGING_DIR" ) | ||
23 | |||
24 | |||
25 | def finalize_options(self): | ||
26 | @@ -49,8 +49,8 @@ class _M2CryptoBuildExt(build_ext.build_ext): | ||
27 | |||
28 | build_ext.build_ext.finalize_options(self) | ||
29 | |||
30 | - opensslIncludeDir = os.path.join(self.openssl, 'include') | ||
31 | - opensslLibraryDir = os.path.join(self.openssl, 'lib') | ||
32 | + opensslIncludeDir = os.environ.get( "STAGING_INCDIR" ) | ||
33 | + opensslLibraryDir = os.environ.get( "STAGING_LIBDIR" ) | ||
34 | |||
35 | self.swig_opts = ['-I%s' % i for i in self.include_dirs + \ | ||
36 | [opensslIncludeDir]] | ||
37 | -- | ||
38 | 1.8.1.4 | ||
39 | |||