diff options
author | Khem Raj <raj.khem@gmail.com> | 2021-05-01 12:04:27 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-05-03 08:05:21 -0700 |
commit | b8bbcd4dea422be57123d75fbf77db6d33542b06 (patch) | |
tree | 17575e74c76687ac01ecdd69aed7a71614941326 /meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch | |
parent | 57baca4bc1b681482bc014508d28f7def5949c33 (diff) | |
download | meta-openembedded-b8bbcd4dea422be57123d75fbf77db6d33542b06.tar.gz |
python3-m2crypto: Upgrade to 0.37.1
Unifiy .inc into .bb
Add patches to fix issues with openssl 1.1.x
Remove m2crypto-0.26.4-gcc_macros patch, its no longer needed
Refresh existing patches
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch | 35 |
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch b/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch deleted file mode 100644 index 7f6dd29f8a..0000000000 --- a/meta-python/recipes-devtools/python/python-m2crypto/m2crypto-0.26.4-gcc_macros.patch +++ /dev/null | |||
@@ -1,35 +0,0 @@ | |||
1 | Imported from Fedora | ||
2 | |||
3 | Index: M2Crypto-0.30.1/SWIG/_m2crypto.i | ||
4 | =================================================================== | ||
5 | --- M2Crypto-0.30.1.orig/SWIG/_m2crypto.i | ||
6 | +++ M2Crypto-0.30.1/SWIG/_m2crypto.i | ||
7 | @@ -8,6 +8,11 @@ | ||
8 | * | ||
9 | */ | ||
10 | |||
11 | +%import "gcc_macros.h" | ||
12 | + | ||
13 | +%ignore WCHAR_MAX; | ||
14 | +%ignore WCHAR_MIN; | ||
15 | + | ||
16 | %module(threads=1) m2crypto | ||
17 | /* We really don't need threadblock (PyGILState_Ensure() etc.) anywhere. | ||
18 | Disable threadallow as well, only enable it for operations likely to | ||
19 | @@ -15,11 +20,6 @@ | ||
20 | %nothreadblock; | ||
21 | %nothreadallow; | ||
22 | |||
23 | -#if SWIG_VERSION >= 0x030000 | ||
24 | -#define __WCHAR_MAX__ __WCHAR_MAX | ||
25 | -#define __WCHAR_MIN__ __WCHAR_MIN | ||
26 | -#endif | ||
27 | - | ||
28 | %{ | ||
29 | #ifdef _WIN32 | ||
30 | #define _WINSOCKAPI_ | ||
31 | @@ -95,4 +95,3 @@ static PyObject *x509_store_verify_cb_fu | ||
32 | %constant int encrypt = 1; | ||
33 | %constant int decrypt = 0; | ||
34 | #endif | ||
35 | - | ||