summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-05-24 09:52:35 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-24 07:23:54 -0700
commit07fad37c9818a9f365c1f82f6f1907cafdb1d1f6 (patch)
tree1870794108a077e2cf18f70ad2fc88680a1c7b0b /meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
parent26397c2ea3fe904cc99cd767c9e2b1c5b3840321 (diff)
downloadmeta-openembedded-07fad37c9818a9f365c1f82f6f1907cafdb1d1f6.tar.gz
meta-python: remove unused patches from python2 recipes
* python2 recipes were removed in: https://git.openembedded.org/meta-openembedded/commit/?id=05d0c5eee319055816bbea8b9dd972f723f68019 but some of the unused patch files were left behind * meta-python/recipes-devtools/python/python-pyrex/pyrex-fix-optimized-mode.patch: https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch meta-python/recipes-devtools/python/python-imaging/fix-freetype-includes.patch meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-numeric_24.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch33
1 files changed, 0 insertions, 33 deletions
diff --git a/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch b/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
deleted file mode 100644
index 941bed3d73..0000000000
--- a/meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch
+++ /dev/null
@@ -1,33 +0,0 @@
1From 3484bdfa7adbaebcf8bb8e7d4820f64b12717932 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 29 Jul 2016 15:37:18 +0800
4Subject: [PATCH] python-mccabe: remove unnecessary setup_requires
5 pytest-runner
6
7* Remove setup_requires pytest-runner as the
8 setup_requires pytest-runner actually is not
9 used for pytest which only in do_compile phase
10 via setup.py build
11
12Upstream-Status: Pending
13
14Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
15---
16 setup.py | 1 -
17 1 file changed, 1 deletion(-)
18
19diff --git a/setup.py b/setup.py
20index e59903d..bf2aaba 100644
21--- a/setup.py
22+++ b/setup.py
23@@ -33,7 +33,6 @@ setup(
24 license='Expat license',
25 py_modules=['mccabe'],
26 zip_safe=False,
27- setup_requires=['pytest-runner'],
28 tests_require=['pytest'],
29 entry_points={
30 'flake8.extension': [
31--
322.8.1
33