summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
diff options
context:
space:
mode:
authorMartin Jansa <martin.jansa@gmail.com>2023-05-24 09:52:35 +0200
committerKhem Raj <raj.khem@gmail.com>2023-05-24 07:23:54 -0700
commit07fad37c9818a9f365c1f82f6f1907cafdb1d1f6 (patch)
tree1870794108a077e2cf18f70ad2fc88680a1c7b0b /meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
parent26397c2ea3fe904cc99cd767c9e2b1c5b3840321 (diff)
downloadmeta-openembedded-07fad37c9818a9f365c1f82f6f1907cafdb1d1f6.tar.gz
meta-python: remove unused patches from python2 recipes
* python2 recipes were removed in: https://git.openembedded.org/meta-openembedded/commit/?id=05d0c5eee319055816bbea8b9dd972f723f68019 but some of the unused patch files were left behind * meta-python/recipes-devtools/python/python-pyrex/pyrex-fix-optimized-mode.patch: https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-pyrex_0.9.9.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-imaging/0001-python-imaging-setup.py-force-paths-for-zlib-freetyp.patch meta-python/recipes-devtools/python/python-imaging/allow.to.disable.some.features.patch meta-python/recipes-devtools/python/python-imaging/fix-freetype-includes.patch meta-python/recipes-devtools/python/python-imaging/python-imaging-CVE-2016-2533.patch meta-python/recipes-devtools/python/python-imaging/remove-host-libdir.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-imaging_1.1.7.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-mccabe/0001-python-mccabe-remove-unnecessary-setup_requires-pyte.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-mccabe_0.4.0.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-pygpgme/0001-reflect-2.1-reporting-for-key-imports.patch meta-python/recipes-devtools/python/python-pygpgme/0002-passphrase_cb-is-deprecated.patch meta-python/recipes-devtools/python/python-pygpgme/0003-handle-generic-error-when-no-passphrase-callback-pre.patch https://git.openembedded.org/meta-openembedded/tree/meta-python/recipes-devtools/python/python-pygpgme_0.3.bb?id=698c36f58434009844b90d7bda1ab38b5af3d62a * meta-python/recipes-devtools/python/python-daemon/0001-Workaround-for-issue-2-1.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-daemon_2.1.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 * meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch https://git.openembedded.org/meta-openembedded/diff/meta-python/recipes-devtools/python/python-numeric_24.2.bb?id=05d0c5eee319055816bbea8b9dd972f723f68019 Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch b/meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
deleted file mode 100644
index 81ed744cbd..0000000000
--- a/meta-python/recipes-devtools/python/python-numeric/0001-it-tries-to-define-this-function-differently-than-it.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1From 322e781c67d7a78fc2cfc3d377f50b825fc64abb Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Fri, 2 Jun 2017 20:21:01 -0700
4Subject: [PATCH] it tries to define this function differently than it is
5 defined in sys/time.h.
6
7Use the definition from system
8
9Signed-off-by: Khem Raj <raj.khem@gmail.com>
10---
11 Packages/RNG/Src/ranf.c | 3 ---
12 1 file changed, 3 deletions(-)
13
14diff --git a/Packages/RNG/Src/ranf.c b/Packages/RNG/Src/ranf.c
15index 5ca7dc5..e669fa8 100644
16--- a/Packages/RNG/Src/ranf.c
17+++ b/Packages/RNG/Src/ranf.c
18@@ -149,9 +149,6 @@ void Mixranf(int *s,u32 s48[2])
19 #else
20 struct timeval tv;
21 struct timezone tz;
22-#if !defined(__sgi)
23- int gettimeofday(struct timeval *, struct timezone *);
24-#endif
25
26 (void)gettimeofday(&tv,&tz);
27 s48[0] = (u32)tv.tv_sec;
28--
292.13.0
30