diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2020-09-25 14:23:21 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-09-28 20:49:15 -0700 |
commit | 80efddfabbee4cc18e33e40ec61ad1ff47b47a6c (patch) | |
tree | e3a8fdd086313fb0e8d810aa2fe74c75ff3e8ae9 /meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch | |
parent | 07843a418b974963e9b2f6d90227433fdc463cd1 (diff) | |
download | meta-openembedded-80efddfabbee4cc18e33e40ec61ad1ff47b47a6c.tar.gz |
python3-pycrypto: Consolidate in a single file
Consolidate inc and bb files into a single bb file.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch | 23 |
1 files changed, 0 insertions, 23 deletions
diff --git a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch b/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch deleted file mode 100644 index 712f3e8dde..0000000000 --- a/meta-python/recipes-devtools/python/python-pycrypto/cross-compiling.patch +++ /dev/null | |||
@@ -1,23 +0,0 @@ | |||
1 | Index: pycrypto-2.6/setup.py | ||
2 | =================================================================== | ||
3 | --- pycrypto-2.6.orig/setup.py | ||
4 | +++ pycrypto-2.6/setup.py | ||
5 | @@ -271,7 +271,8 @@ class PCTBuildConfigure(Command): | ||
6 | if not os.path.exists("config.status"): | ||
7 | if os.system("chmod 0755 configure") != 0: | ||
8 | raise RuntimeError("chmod error") | ||
9 | - cmd = "sh configure" # we use "sh" here so that it'll work on mingw32 with standard python.org binaries | ||
10 | + host = os.environ.get("HOST_SYS") | ||
11 | + cmd = "ac_cv_func_malloc_0_nonnull=yes sh configure --host " + host # we use "sh" here so that it'll work on mingw32 with standard python.org binaries | ||
12 | if self.verbose < 1: | ||
13 | cmd += " -q" | ||
14 | if os.system(cmd) != 0: | ||
15 | @@ -370,7 +371,7 @@ kw = {'name':"pycrypto", | ||
16 | 'ext_modules': plat_ext + [ | ||
17 | # _fastmath (uses GNU mp library) | ||
18 | Extension("Crypto.PublicKey._fastmath", | ||
19 | - include_dirs=['src/','/usr/include/'], | ||
20 | + include_dirs=['src/'], | ||
21 | libraries=['gmp'], | ||
22 | sources=["src/_fastmath.c"]), | ||
23 | |||