summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pyopenssl-0.13
diff options
context:
space:
mode:
authorLi xin <lixin.fnst@cn.fujitsu.com>2015-08-07 13:51:42 +0800
committerMartin Jansa <Martin.Jansa@gmail.com>2015-08-24 13:56:26 +0200
commit82476e6f80ebc6b4fb20fc8fe4326a2403d2da69 (patch)
tree1e6fbb7d7e30e79ab109cd1a87ec5e47f4f28547 /meta-python/recipes-devtools/python/python-pyopenssl-0.13
parent44bd0256d8ded535f3e214327fa7fbcc4b267dbb (diff)
downloadmeta-openembedded-82476e6f80ebc6b4fb20fc8fe4326a2403d2da69.tar.gz
python-pyopenssl: upgrade 0.13 -> 0.15.1
* Dropped x509_revoked_dup.patch,since the original file crl.c does not exist anymore. * Add DEPENDS python-cryptography to aviod build errors: | error: Could not find suitable distribution for Requirement.parse('six>=1.5.2') | ERROR: python setup.py install execution failed. Signed-off-by: Li Xin <lixin.fnst@cn.fujitsu.com> Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyopenssl-0.13')
-rw-r--r--meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch19
1 files changed, 0 insertions, 19 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch b/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch
deleted file mode 100644
index c386e9ccd6..0000000000
--- a/meta-python/recipes-devtools/python/python-pyopenssl-0.13/x509_revoked_dup.patch
+++ /dev/null
@@ -1,19 +0,0 @@
1diff -Naur pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c pyOpenSSL-0.13/OpenSSL/crypto/crl.c
2--- pyOpenSSL-0.13.orig/OpenSSL/crypto/crl.c 2011-09-02 17:46:13.000000000 +0200
3+++ pyOpenSSL-0.13/OpenSSL/crypto/crl.c 2015-03-26 20:53:08.984999223 +0100
4@@ -3,6 +3,7 @@
5 #include "crypto.h"
6
7
8+#if 0
9 static X509_REVOKED * X509_REVOKED_dup(X509_REVOKED *orig) {
10 X509_REVOKED *dupe = NULL;
11
12@@ -32,6 +33,7 @@
13 dupe->sequence = orig->sequence;
14 return dupe;
15 }
16+#endif
17
18 static char crypto_CRL_get_revoked_doc[] = "\n\
19 Return revoked portion of the CRL structure (by value\n\