diff options
author | Derek Straka <derek@asterius.io> | 2020-04-04 14:21:04 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2020-04-05 10:38:14 -0700 |
commit | 1d870c0ee51b11eb42e2533c8bd428e6654ef454 (patch) | |
tree | 00687219d16bdfdb3d2a24592e7e4cecea3625b9 /meta-python/recipes-devtools/python/python-pytest.inc | |
parent | 273ea761e1446e69c118280266a75737a3d42a85 (diff) | |
download | meta-openembedded-1d870c0ee51b11eb42e2533c8bd428e6654ef454.tar.gz |
python-pytest: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest.inc')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest.inc | 41 |
1 files changed, 0 insertions, 41 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc deleted file mode 100644 index 40ca9c2f13..0000000000 --- a/meta-python/recipes-devtools/python/python-pytest.inc +++ /dev/null | |||
@@ -1,41 +0,0 @@ | |||
1 | SUMMARY = "Simple powerful testing with python" | ||
2 | HOMEPAGE = "http://pytest.org" | ||
3 | LICENSE = "MIT" | ||
4 | LIC_FILES_CHKSUM = "file://LICENSE;md5=81eb9f71d006c6b268cf4388e3c98f7b" | ||
5 | |||
6 | SRC_URI[md5sum] = "d5ef453f723be46d93e0795f3be86c88" | ||
7 | SRC_URI[sha256sum] = "0d5fe9189a148acc3c3eb2ac8e1ac0742cb7618c084f3d228baaec0c254b318d" | ||
8 | |||
9 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \ | ||
10 | " | ||
11 | |||
12 | inherit update-alternatives | ||
13 | |||
14 | RDEPENDS_${PN}_class-target += " \ | ||
15 | ${PYTHON_PN}-attrs \ | ||
16 | ${PYTHON_PN}-debugger \ | ||
17 | ${PYTHON_PN}-doctest \ | ||
18 | ${PYTHON_PN}-json \ | ||
19 | ${PYTHON_PN}-pluggy \ | ||
20 | ${PYTHON_PN}-py \ | ||
21 | ${PYTHON_PN}-setuptools \ | ||
22 | ${PYTHON_PN}-six \ | ||
23 | ${PYTHON_PN}-atomicwrites \ | ||
24 | ${PYTHON_PN}-importlib-metadata \ | ||
25 | ${PYTHON_PN}-pathlib2 \ | ||
26 | ${PYTHON_PN}-wcwidth \ | ||
27 | ${PYTHON_PN}-more-itertools \ | ||
28 | ${PYTHON_PN}-packaging \ | ||
29 | " | ||
30 | |||
31 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:" | ||
32 | |||
33 | ALTERNATIVE_${PN} += "py.test pytest" | ||
34 | |||
35 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" | ||
36 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" | ||
37 | |||
38 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" | ||
39 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" | ||
40 | |||
41 | BBCLASSEXTEND = "native nativesdk" | ||