diff options
author | leimaohui <leimaohui@cn.fujitsu.com> | 2018-05-27 17:34:16 -0700 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-06-20 10:07:41 -0700 |
commit | 28fab4c8f547d45b80bb7b06d33a6c6c1ea74efc (patch) | |
tree | adcf32bc96199c3e01f01bfabfa6766082ef064a /meta-python/recipes-devtools/python/python-pytest.inc | |
parent | a5ea75f5161950fb204852d1a1ddfb4acd5a720e (diff) | |
download | meta-openembedded-28fab4c8f547d45b80bb7b06d33a6c6c1ea74efc.tar.gz |
python-pytest: Fix conflict error as following:
file /usr/bin/py.test conflicts between attempted installs of python3-pytest-3.4.2-r0 and python-pytest-3.4.2-r0
file /usr/bin/pytest conflicts between attempted installs of python3-pytest-3.4.2-r0 and python-pytest-3.4.2-r0
Signed-off-by: Lei Maohui <leimaohui@cn.fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest.inc')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pytest.inc | 10 |
1 files changed, 10 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest.inc b/meta-python/recipes-devtools/python/python-pytest.inc index 4feb9a03cf..4c32dfb044 100644 --- a/meta-python/recipes-devtools/python/python-pytest.inc +++ b/meta-python/recipes-devtools/python/python-pytest.inc | |||
@@ -9,6 +9,8 @@ SRC_URI[sha256sum] = "117bad36c1a787e1a8a659df35de53ba05f9f3398fb9e4ac17e80ad590 | |||
9 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \ | 9 | SRC_URI_append = " file://0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch \ |
10 | file://pytest_version_fix.patch " | 10 | file://pytest_version_fix.patch " |
11 | 11 | ||
12 | inherit update-alternatives | ||
13 | |||
12 | RDEPENDS_${PN}_class-target += " \ | 14 | RDEPENDS_${PN}_class-target += " \ |
13 | ${PYTHON_PN}-attrs \ | 15 | ${PYTHON_PN}-attrs \ |
14 | ${PYTHON_PN}-debugger \ | 16 | ${PYTHON_PN}-debugger \ |
@@ -22,4 +24,12 @@ RDEPENDS_${PN}_class-target += " \ | |||
22 | 24 | ||
23 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:" | 25 | FILESEXTRAPATHS_prepend := "${THISDIR}/python-pytest:" |
24 | 26 | ||
27 | ALTERNATIVE_${PN} += "py.test pytest" | ||
28 | |||
29 | NATIVE_LINK_NAME[pytest] = "${bindir}/pytest" | ||
30 | ALTERNATIVE_TARGET[pytest] = "${bindir}/pytest" | ||
31 | |||
32 | ALTERNATIVE_LINK_NAME[py.test] = "${bindir}/py.test" | ||
33 | ALTERNATIVE_TARGET[py.test] = "${bindir}/py.test" | ||
34 | |||
25 | BBCLASSEXTEND = "native nativesdk" | 35 | BBCLASSEXTEND = "native nativesdk" |