summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
diff options
context:
space:
mode:
authorDerek Straka <derek@asterius.io>2020-04-04 14:21:04 -0400
committerKhem Raj <raj.khem@gmail.com>2020-04-05 10:38:14 -0700
commit1d870c0ee51b11eb42e2533c8bd428e6654ef454 (patch)
tree00687219d16bdfdb3d2a24592e7e4cecea3625b9 /meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
parent273ea761e1446e69c118280266a75737a3d42a85 (diff)
downloadmeta-openembedded-1d870c0ee51b11eb42e2533c8bd428e6654ef454.tar.gz
python-pytest: consolidate inc and bb files into a single bb file
Signed-off-by: Derek Straka <derek@asterius.io> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch')
-rw-r--r--meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch36
1 files changed, 0 insertions, 36 deletions
diff --git a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch b/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
deleted file mode 100644
index c29fb12de8..0000000000
--- a/meta-python/recipes-devtools/python/python-pytest/0001-setup.py-remove-the-setup_requires-for-setuptools-scm.patch
+++ /dev/null
@@ -1,36 +0,0 @@
1From ff784f4803ab33f5e3389e40d038d52d1e211843 Mon Sep 17 00:00:00 2001
2From: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
3Date: Wed, 28 Aug 2019 16:12:27 +0900
4Subject: [PATCH] [PATCH] setup.py: remove the setup_requires for
5 setuptools-scm
6
7The setup_requires argument forces the download of the egg file for setuptools-scm
8during the do_compile phase. This download is incompatible with the typical fetch
9and mirror structure. The only usage of scm is the generation of the _version.py
10file and in the release tarball it is already correctly created
11
12Upstream-Status: Inappropriate [oe specific]
13
14Signed-off-by: Derek Straka <derek@asterius.io>
15
16Signed-off-by: Yuan Chao <yuanc.fnst@cn.fujitsu.com>
17---
18 setup.py | 2 +-
19 1 file changed, 1 insertion(+), 1 deletion(-)
20
21diff --git a/setup.py b/setup.py
22index adbafb5..75fdd09 100644
23--- a/setup.py
24+++ b/setup.py
25@@ -19,7 +19,7 @@ INSTALL_REQUIRES = [
26 def main():
27 setup(
28 use_scm_version={"write_to": "src/_pytest/_version.py"},
29- setup_requires=["setuptools-scm", "setuptools>=40.0"],
30+ setup_requires=["setuptools>=40.0"],
31 package_dir={"": "src"},
32 extras_require={
33 "testing": [
34--
352.17.1
36