diff options
author | Pascal Bach <pascal.bach@siemens.com> | 2018-07-19 09:25:01 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2018-07-20 16:07:12 -0700 |
commit | 625e1e58d006938396c826dc9de56b0d0ca308a9 (patch) | |
tree | 5b7797f799b3a8596f00f8741fc4429530e80afd /meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | |
parent | b0caf1fb82b90a6b123ba4463a8405568eda0389 (diff) | |
download | meta-openembedded-625e1e58d006938396c826dc9de56b0d0ca308a9.tar.gz |
python-pyzmq, python3-pyzmq: update to 17.1.0
Also the package is licensed under both BSD and LGPL-3.0.
This the license checksum was updated to reflect this.
Signed-off-by: Pascal Bach <pascal.bach@siemens.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | 31 |
1 files changed, 9 insertions, 22 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch index 2dc3b73f9e..936f165850 100644 --- a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch +++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | |||
@@ -1,26 +1,13 @@ | |||
1 | diff --git a/setup.py b/setup.py | 1 | diff --git a/setup.py b/setup.py |
2 | index 62df445..1fdbdeb 100755 | 2 | index d243eaa..98099bc 100755 |
3 | --- a/setup.py | 3 | --- a/setup.py |
4 | +++ b/setup.py | 4 | +++ b/setup.py |
5 | @@ -213,12 +213,6 @@ def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False): | 5 | @@ -192,8 +192,6 @@ def _add_rpath(settings, path): |
6 | pass | 6 | """ |
7 | # unused rpath args for OS X: | 7 | if sys.platform == 'darwin': |
8 | # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/..'] | 8 | settings['extra_link_args'].extend(['-Wl,-rpath','-Wl,%s' % path]) |
9 | - else: | 9 | - else: |
10 | - settings['runtime_library_dirs'] += ['$ORIGIN/..'] | 10 | - settings['runtime_library_dirs'].append(path) |
11 | - elif sys.platform != 'darwin': | ||
12 | - settings['runtime_library_dirs'] += [ | ||
13 | - os.path.abspath(x) for x in settings['library_dirs'] | ||
14 | - ] | ||
15 | |||
16 | return settings | ||
17 | 11 | ||
18 | @@ -592,8 +586,6 @@ class Configure(build_ext): | 12 | def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False): |
19 | pass | 13 | """load appropriate library/include settings from ZMQ prefix""" |
20 | # unused rpath args for OS X: | ||
21 | # settings['extra_link_args'] = ['-Wl,-rpath','-Wl,$ORIGIN/../zmq'] | ||
22 | - else: | ||
23 | - settings['runtime_library_dirs'] = [ os.path.abspath(pjoin('.', 'zmq')) ] | ||
24 | |||
25 | line() | ||
26 | info("Configure: Autodetecting ZMQ settings...") | ||