diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-01-29 15:10:28 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-02-01 10:44:46 -0800 |
commit | dc8afb18c1cea424e175473ab6ad550bd3809f40 (patch) | |
tree | 44e958c6b6efa94e39c86f346b83aa4355dbcad4 /meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | |
parent | 10ffcd08e05e799674ec4fab1e41b746801ce464 (diff) | |
download | meta-openembedded-dc8afb18c1cea424e175473ab6ad550bd3809f40.tar.gz |
python3-pyzmq: Upgrade 21.0.2 -> 22.0.2
Upgrade to release 22.0.2:
- Add workaround for bug in DLL loading for Windows wheels with
conda Python >= 3.8
- Fix type of Frame.bytes for non-copying recvs with CFFI backend
(regression in 21.0)
- Add manylinux wheels for pypy
- Some typing fixes
- Bump bundled libzmq to 4.3.4
- Strip unused symbols in manylinux wheels, resulting in
dramatically smaller binaries. This matches behavior in v20 and
earlier.
- Windows CPython wheels bundle public libzmq binary builds,
instead of building libzmq as a Python Extension. This means
they include libsodium for the first time.
- Our own implementation of bundling libzmq into pyzmq on Windows
is removed, instead relying on delvewheel (or installations
putting dlls on %PATH%) to bundle dependency dlls.
- The (new in 21.0) Windows wheels for PyPy likely require the
Windows vcredist package. This may have always been the case,
but the delvewheel approach doesn't seem to work.
- Windows + PyPy is now the only remaining case where a wheel has
libzmq built as an Extension. All other builds ship libzmq built
using its own tooling, which should result in better, more
stable builds.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | 12 |
1 files changed, 5 insertions, 7 deletions
diff --git a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch index d4e144a610..61aeaca5fa 100644 --- a/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch +++ b/meta-python/recipes-devtools/python/python-pyzmq/club-rpath-out.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From b394003d31a7187767b7d6cc7b871968d2674be9 Mon Sep 17 00:00:00 2001 | 1 | From efae4e08d13e0958d929ea524e21c0a210b31982 Mon Sep 17 00:00:00 2001 |
2 | From: Leon Anavi <leon.anavi@konsulko.com> | 2 | From: Leon Anavi <leon.anavi@konsulko.com> |
3 | Date: Fri, 22 Jan 2021 11:41:12 +0200 | 3 | Date: Fri, 22 Jan 2021 11:41:12 +0200 |
4 | Subject: [PATCH] setup.py: Adjust _add_rpath | 4 | Subject: [PATCH] setup.py: Adjust _add_rpath |
@@ -8,15 +8,16 @@ Fix error: unrecognized command-line option '-R' | |||
8 | Upstream-Status: Inappropriate [oe specific] | 8 | Upstream-Status: Inappropriate [oe specific] |
9 | 9 | ||
10 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | 10 | Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> |
11 | |||
11 | --- | 12 | --- |
12 | setup.py | 3 --- | 13 | setup.py | 3 --- |
13 | 1 file changed, 3 deletions(-) | 14 | 1 file changed, 3 deletions(-) |
14 | 15 | ||
15 | diff --git a/setup.py b/setup.py | 16 | diff --git a/setup.py b/setup.py |
16 | index 22f582d..2d28655 100755 | 17 | index b634d94..7f6a2f1 100755 |
17 | --- a/setup.py | 18 | --- a/setup.py |
18 | +++ b/setup.py | 19 | +++ b/setup.py |
19 | @@ -231,9 +231,6 @@ def _add_rpath(settings, path): | 20 | @@ -235,9 +235,6 @@ def _add_rpath(settings, path): |
20 | """ | 21 | """ |
21 | if sys.platform == 'darwin': | 22 | if sys.platform == 'darwin': |
22 | settings['extra_link_args'].extend(['-Wl,-rpath', '-Wl,%s' % path]) | 23 | settings['extra_link_args'].extend(['-Wl,-rpath', '-Wl,%s' % path]) |
@@ -24,8 +25,5 @@ index 22f582d..2d28655 100755 | |||
24 | - settings['runtime_library_dirs'].append(path) | 25 | - settings['runtime_library_dirs'].append(path) |
25 | - | 26 | - |
26 | 27 | ||
27 | def settings_from_prefix(prefix=None, bundle_libzmq_dylib=False): | 28 | def settings_from_prefix(prefix=None): |
28 | """load appropriate library/include settings from ZMQ prefix""" | 29 | """load appropriate library/include settings from ZMQ prefix""" |
29 | -- | ||
30 | 2.17.1 | ||
31 | |||