summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
diff options
context:
space:
mode:
authorNicola Lunghi <nick83ola@gmail.com>2019-11-14 12:48:52 +0000
committerKhem Raj <raj.khem@gmail.com>2019-11-14 10:12:07 -0800
commit4124042b7dcf4fa21e4e22c043c7846d08d30c31 (patch)
treea0bc2116889c483eca4e53697393d610ebe9b7ff /meta-python/recipes-devtools/python/python-rfc3986-validator.inc
parentdd81e462f703053c4da715458da2758ae7ca900b (diff)
downloadmeta-openembedded-4124042b7dcf4fa21e4e22c043c7846d08d30c31.tar.gz
python-rfc3986-validator: add recipe
This is an optional dependency for python-jsonschema Signed-off-by: Nicola Lunghi <nick83ola@gmail.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python-rfc3986-validator.inc')
-rw-r--r--meta-python/recipes-devtools/python/python-rfc3986-validator.inc23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python-rfc3986-validator.inc b/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
new file mode 100644
index 0000000000..71f7a7904f
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python-rfc3986-validator.inc
@@ -0,0 +1,23 @@
1SUMMARY = "Pure python rfc3986 validator"
2HOMEPAGE = "https://github.com/naimetti/rfc3986-validator"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=a21b13b5a996f08f7e0b088aa38ce9c6"
5
6FILESEXTRAPATHS_prepend := "${THISDIR}/python-rfc3986-validator:"
7
8SRC_URI[md5sum] = "47f7657b790aaf6011a1ab3d86c6be95"
9SRC_URI[sha256sum] = "3d44bde7921b3b9ec3ae4e3adca370438eccebc676456449b145d533b240d055"
10
11PYPI_PACKAGE = "rfc3986_validator"
12
13inherit pypi
14
15SRC_URI_append = " \
16 file://0001-setup.py-move-pytest-runner-to-test_requirements.patch \
17"
18
19RDEPENDS_${PN} += "\
20 python3-core \
21"
22
23BBCLASSEXTEND = "native nativesdk"