summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.1.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2022-03-09 18:44:01 +0800
committerTrevor Gamblin <trevor.gamblin@windriver.com>2022-03-10 10:03:29 -0500
commit87e1c68ec1f98c38a9e91c0553e5b513865b1c20 (patch)
treefc9e4e499d08b2e2087a7aa8d8d6fb0754d0f2c0 /meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.1.bb
parent9b1f94bb6ac07d6f2147443046f275523094b877 (diff)
downloadmeta-openembedded-87e1c68ec1f98c38a9e91c0553e5b513865b1c20.tar.gz
python3-aws-iot-device-sdk-python: upgrade 1.5.0-> 1.5.1
Changelog: ========= change append to extend to fix bytestream error Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.1.bb44
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.1.bb b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.1.bb
new file mode 100644
index 0000000000..0b2181e4fe
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-aws-iot-device-sdk-python_1.5.1.bb
@@ -0,0 +1,44 @@
1DESCRIPTION = "SDK for connecting to AWS IoT using Python."
2HOMEPAGE = "https://github.com/aws/aws-iot-device-sdk-python"
3LICENSE = "Apache-2.0 & (EPL-1.0 | EDL-1.0)"
4LICENSE:${PN}-examples = "Apache-2.0"
5LIC_FILES_CHKSUM = "\
6 file://LICENSE.txt;md5=9ac49901b833e769c7d6f21e8dbd7b30 \
7 file://AWSIoTPythonSDK/core/protocol/paho/client.py;endline=14;md5=5a3c8a1a4bb71bd934f450ecff972ad9 \
8"
9SRCREV = "6ca6c73775c953114f83240a850a0d1ab49b68ac"
10SRC_URI = "git://github.com/aws/aws-iot-device-sdk-python;branch=master;protocol=https \
11 file://0001-setup.py-Use-setuptools-instead-of-distutils.patch \
12 "
13
14S = "${WORKDIR}/git"
15
16inherit setuptools3
17
18PYPI_PACKAGE = "AWSIoTPythonSDK"
19
20do_install:append() {
21 install -d -m0755 ${D}${datadir}/${BPN}/examples
22 cp --preserve=mode,timestamps -R ${S}/samples/* ${D}${datadir}/${BPN}/examples
23 # this requires the full blown AWS Python SDK
24 rm -r ${D}${datadir}/${BPN}/examples/basicPubSub
25}
26
27PACKAGES =+ "${PN}-examples"
28
29RDEPENDS:${PN} += " \
30 ${PYTHON_PN}-crypt \
31 ${PYTHON_PN}-datetime \
32 ${PYTHON_PN}-io \
33 ${PYTHON_PN}-json \
34 ${PYTHON_PN}-logging \
35 ${PYTHON_PN}-math \
36 ${PYTHON_PN}-netclient \
37 ${PYTHON_PN}-numbers \
38 ${PYTHON_PN}-threading \
39"
40RDEPENDS:${PN}-examples += "${PN}"
41
42FILES:${PN}-examples = "${datadir}/${BPN}/examples"
43
44BBCLASSEXTEND = "native nativesdk"