summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-02-28 15:23:43 -0500
committerKhem Raj <raj.khem@gmail.com>2022-03-01 09:06:56 -0800
commit11e32240154e05a4ed23b1b70788e48bf1a6efab (patch)
tree6eff1e88a147033f01a9978d8f65c9e0366eed2d /meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch
parent8988542616cc709cc23732243e4785ea36dd25a4 (diff)
downloadmeta-openembedded-11e32240154e05a4ed23b1b70788e48bf1a6efab.tar.gz
python3-bitarray: switch to setuptools
Backported patch from https://github.com/ilanschnell/bitarray/pull/168, committed upstream as https://github.com/ilanschnell/bitarray/commit/947d364841954d60bab7a4cf1497a272b1bf73ca Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch
new file mode 100644
index 0000000000..cef7ce15a4
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch
@@ -0,0 +1,29 @@
1From 947d364841954d60bab7a4cf1497a272b1bf73ca Mon Sep 17 00:00:00 2001
2From: Konrad Weihmann <kweihmann@outlook.com>
3Date: Sun, 27 Feb 2022 11:57:09 +0100
4Subject: [PATCH] setup.py: use setuptools instead of distutils
5
6as distutils will be deprecated in python 3.12 and already produces
7a warning when run with python 3.10.x, it might be a good time to
8switch to setuptools.
9It offers the same interface, so results will be the same
10
11Signed-off-by: Konrad Weihmann <kweihmann@outlook.com>
12
13Upstream-Status: Backport [https://github.com/ilanschnell/bitarray/commit/947d364841954d60bab7a4cf1497a272b1bf73ca]
14
15---
16 setup.py | 2 +-
17 1 file changed, 1 insertion(+), 1 deletion(-)
18
19diff --git a/setup.py b/setup.py
20index 4dbdf859..c7787dad 100644
21--- a/setup.py
22+++ b/setup.py
23@@ -1,5 +1,5 @@
24 import re
25-from distutils.core import setup, Extension
26+from setuptools import setup, Extension
27
28
29 kwds = {}