diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2022-03-09 18:44:02 +0800 |
---|---|---|
committer | Trevor Gamblin <trevor.gamblin@windriver.com> | 2022-03-10 10:03:29 -0500 |
commit | 9b1f94bb6ac07d6f2147443046f275523094b877 (patch) | |
tree | b2162a1c7c38d09448366baaa74398154837346a /meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch | |
parent | 4700abe43824ad50c9731e60f5ea9357ac5606f7 (diff) | |
download | meta-openembedded-9b1f94bb6ac07d6f2147443046f275523094b877.tar.gz |
python3-bitarray: upgrade 2.3.7 -> 2.4.0
setup.py-use-setuptools-instead-of-distutils.patch
removed since it's included in 2.4.0
Changelog:
=========
* enable building wheels for multiple platforms and Python versions using
pypa/cibuildwheel, see #165 and #170
* use setuptools instead of distutils in 'setup.py', #168
* add missing type hinting for '.count()' step argument
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch | 29 |
1 files changed, 0 insertions, 29 deletions
diff --git a/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch b/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch deleted file mode 100644 index cef7ce15a4..0000000000 --- a/meta-python/recipes-devtools/python/python3-bitarray/setup.py-use-setuptools-instead-of-distutils.patch +++ /dev/null | |||
@@ -1,29 +0,0 @@ | |||
1 | From 947d364841954d60bab7a4cf1497a272b1bf73ca Mon Sep 17 00:00:00 2001 | ||
2 | From: Konrad Weihmann <kweihmann@outlook.com> | ||
3 | Date: Sun, 27 Feb 2022 11:57:09 +0100 | ||
4 | Subject: [PATCH] setup.py: use setuptools instead of distutils | ||
5 | |||
6 | as distutils will be deprecated in python 3.12 and already produces | ||
7 | a warning when run with python 3.10.x, it might be a good time to | ||
8 | switch to setuptools. | ||
9 | It offers the same interface, so results will be the same | ||
10 | |||
11 | Signed-off-by: Konrad Weihmann <kweihmann@outlook.com> | ||
12 | |||
13 | Upstream-Status: Backport [https://github.com/ilanschnell/bitarray/commit/947d364841954d60bab7a4cf1497a272b1bf73ca] | ||
14 | |||
15 | --- | ||
16 | setup.py | 2 +- | ||
17 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
18 | |||
19 | diff --git a/setup.py b/setup.py | ||
20 | index 4dbdf859..c7787dad 100644 | ||
21 | --- a/setup.py | ||
22 | +++ b/setup.py | ||
23 | @@ -1,5 +1,5 @@ | ||
24 | import re | ||
25 | -from distutils.core import setup, Extension | ||
26 | +from setuptools import setup, Extension | ||
27 | |||
28 | |||
29 | kwds = {} | ||