diff options
author | Tim Orling <ticotimo@gmail.com> | 2022-01-15 21:29:04 -0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-01-18 08:59:58 -0800 |
commit | 8589b69f9ff283ec3ae990466bed3b84702eb8e1 (patch) | |
tree | 9fd5a6bfa76ae8c439b1b1afed94d770811d944b /meta-python/recipes-devtools/python/python3-cryptography/h-test.patch | |
parent | 6fecc883380c4dcfbb642464061aa4c51a4626ee (diff) | |
download | meta-openembedded-8589b69f9ff283ec3ae990466bed3b84702eb8e1.tar.gz |
python3-cryptography: upgrade 3.3.2 -> 36.0.1
See https://github.com/pyca/cryptography/blob/main/CHANGELOG.rst#3601---2021-12-14
for changes
* Add PSF-2.0 license and explicitly add checksums for the LICENSE files that
are packaged.
* RDEPENDS on python3-hypothesis (in oe-core) for ptest so we can drop the
patch for skipping.
* Drop backported patch for openssl3 support.
* inherit new setuptools_rust class (which inherits new pyo3 class, which
inherits cargo and python3-dir).
* RDEPENDS on python3-pytest-subtests for ptest
* Copy pyproject.toml for ptest as it defines the pytest.marker(s) needed
* Cleanup and alphabetize the RDEPENDS
* Use 'cargo bitbake' to generate the crate:// SRC_URIs
- Needed some hacks to the Cargo.toml in src/rust/ to make this work (probably
only package.repository was strictly required):
[package]
description = "cryptography includes both high level recipes and low level interfaces to common cryptographic algorithms such as symmetric ciphers, message digests, and key derivation functions."
homepage = "https://github.com/pyca/cryptography"
repository = "https://github.com/pyca/cryptography"
* Add patches to src/rust/Cargo.toml to fix cargo errors including pem version
* Add check-memfree.py to ptest to check for sufficient free memory
Signed-off-by: Tim Orling <tim.orling@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography/h-test.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-cryptography/h-test.patch | 10 |
1 files changed, 0 insertions, 10 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch b/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch deleted file mode 100644 index 9f07c73803..0000000000 --- a/meta-python/recipes-devtools/python/python3-cryptography/h-test.patch +++ /dev/null | |||
@@ -1,10 +0,0 @@ | |||
1 | --- a/tests/hypothesis/__init__.py | ||
2 | +++ b/tests/hypothesis/__init__.py | ||
3 | @@ -3,3 +3,7 @@ | ||
4 | # for complete details. | ||
5 | |||
6 | from __future__ import absolute_import, division, print_function | ||
7 | + | ||
8 | +import pytest | ||
9 | +hypothesis = pytest.importorskip("hypothesis") | ||
10 | + | ||