summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-cryptography
diff options
context:
space:
mode:
authorAlejandro Enedino Hernandez Samaniego <alejandro.hernandez@linux.microsoft.com>2022-03-13 20:03:28 -0600
committertgamblin <trevor.gamblin@windriver.com>2022-03-16 09:25:28 -0400
commitbb9d3688f1b5a5f91ee3e1675bd802c5f9c189f3 (patch)
tree9cce95f2998ab0ffffd88d8ffe67590773da0e66 /meta-python/recipes-devtools/python/python3-cryptography
parentb2c6326c9c0b93d71a150500b304b23ea007f117 (diff)
downloadmeta-openembedded-bb9d3688f1b5a5f91ee3e1675bd802c5f9c189f3.tar.gz
meta-python: Clean up recipes and classes that were moved to oe-core
Signed-off-by: Alejandro Enedino Hernandez Samaniego <alejandro.hernandez@linux.microsoft.com> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: tgamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-cryptography')
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch31
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch28
-rwxr-xr-xmeta-python/recipes-devtools/python/python3-cryptography/check-memfree.py10
-rw-r--r--meta-python/recipes-devtools/python/python3-cryptography/run-ptest4
4 files changed, 0 insertions, 73 deletions
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch b/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch
deleted file mode 100644
index d7ab757bb5..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography/0001-Cargo.toml-specify-pem-version.patch
+++ /dev/null
@@ -1,31 +0,0 @@
1From ec8d3f3c61280c8140b34ed1479baef5e706f064 Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Fri, 14 Jan 2022 22:02:25 -0800
4Subject: [PATCH] Cargo.toml: specify pem version
5
6pem = "1.0" is not resolving, specify the current
7pem = { version: "1.0.2"}
8
9Upstream-Status: Pending
10
11Signed-off-by: Tim Orling <tim.orling@konsulko.com>
12---
13 src/rust/Cargo.toml | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
17index 617167d0..174eaa80 100644
18--- a/src/rust/Cargo.toml
19+++ b/src/rust/Cargo.toml
20@@ -9,7 +9,7 @@ publish = false
21 lazy_static = "1"
22 pyo3 = { version = "0.15.1" }
23 asn1 = { version = "0.8.7", default-features = false, features = ["derive"] }
24-pem = "1.0"
25+pem = { version = "1.0.2" }
26 chrono = { version = "0.4", default-features = false, features = ["alloc", "clock"] }
27 ouroboros = "0.13"
28
29--
302.30.2
31
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch b/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch
deleted file mode 100644
index 366e3a4d39..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography/0002-Cargo.toml-edition-2018-2021.patch
+++ /dev/null
@@ -1,28 +0,0 @@
1From 4b73298b214a5b69ea6edf3c2e21dd82b2b29708 Mon Sep 17 00:00:00 2001
2From: Tim Orling <tim.orling@konsulko.com>
3Date: Fri, 14 Jan 2022 22:34:59 -0800
4Subject: [PATCH 2/2] Cargo.toml: edition 2018 -> 2021
5
6Upstream-Status: Pending
7
8Signed-off-by: Tim Orling <tim.orling@konsulko.com>
9---
10 src/rust/Cargo.toml | 2 +-
11 1 file changed, 1 insertion(+), 1 deletion(-)
12
13diff --git a/src/rust/Cargo.toml b/src/rust/Cargo.toml
14index 174eaa80..7ad053d9 100644
15--- a/src/rust/Cargo.toml
16+++ b/src/rust/Cargo.toml
17@@ -2,7 +2,7 @@
18 name = "cryptography-rust"
19 version = "0.1.0"
20 authors = ["The cryptography developers <cryptography-dev@python.org>"]
21-edition = "2018"
22+edition = "2021"
23 publish = false
24
25 [dependencies]
26--
272.30.2
28
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py b/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py
deleted file mode 100755
index c111a9074c..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography/check-memfree.py
+++ /dev/null
@@ -1,10 +0,0 @@
1#!/usr/bin/env python3
2# https://stackoverflow.com/questions/22102999/get-total-physical-memory-in-python/28161352
3import sys
4meminfo = dict((i.split()[0].rstrip(':'),int(i.split()[1])) for i in open('/proc/meminfo').readlines())
5mem_free = meminfo['MemTotal']/1024./1024.
6if mem_free < 2.:
7 raise RuntimeError("Insufficient free memory({:.3f}): requires > 2 GB".format(mem_free))
8 sys.exit(1)
9else:
10 print("Free memory: {:.3f} GB".format(mem_free))
diff --git a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest b/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
deleted file mode 100644
index 1e97dda63e..0000000000
--- a/meta-python/recipes-devtools/python/python3-cryptography/run-ptest
+++ /dev/null
@@ -1,4 +0,0 @@
1#!/bin/sh
2if ./check-memfree.py; then
3 pytest -vvvv tests/
4fi