summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2025-05-18 10:27:41 -0700
committerKhem Raj <raj.khem@gmail.com>2025-05-19 08:37:19 -0700
commit8803832e70274b14c00f6b7806a22ebf6dd4ffa9 (patch)
tree5b22e5662379cf2fdcc1e874c1e70eb19bf3187d /meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch
parentbf17b7294f405afc24cc2a18731cc73050d760b5 (diff)
downloadmeta-openembedded-8803832e70274b14c00f6b7806a22ebf6dd4ffa9.tar.gz
python3-dbus-fast: Fix build with cython 3.1
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch b/meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch
new file mode 100644
index 0000000000..fb8f4df4a6
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-dbus-fast/0001-pyproject.toml-Remove-upper-version-constraint-for-C.patch
@@ -0,0 +1,33 @@
1From 85189fb66d3abb2645605f8a3c14d8152ef755fe Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Sun, 18 May 2025 10:24:19 -0700
4Subject: [PATCH] pyproject.toml: Remove upper version constraint for Cython
5
6Upstream-Status: Pending
7Signed-off-by: Khem Raj <raj.khem@gmail.com>
8---
9 pyproject.toml | 4 ++--
10 1 file changed, 2 insertions(+), 2 deletions(-)
11
12diff --git a/pyproject.toml b/pyproject.toml
13index e22ea42..f670d3d 100644
14--- a/pyproject.toml
15+++ b/pyproject.toml
16@@ -50,7 +50,7 @@ pytest-cov = ">=3,<7"
17 pytest-asyncio = ">=0.19,<0.27"
18 pycairo = "^1.21.0"
19 PyGObject = {version = ">=3.50,<3.51", python = "<4"}
20-Cython = ">=3,<3.1.0"
21+Cython = ">=3"
22 setuptools = ">=65.4.1,<79.0.0"
23 pytest-timeout = "^2.1.0"
24 pytest-codspeed = "^3.1.1"
25@@ -104,7 +104,7 @@ module = "docs.*"
26 ignore_errors = true
27
28 [build-system]
29-requires = ['setuptools>=65.4.1', 'wheel', 'Cython>=3,<3.1.0', "poetry-core>=1.0.0"]
30+requires = ['setuptools>=65.4.1', 'wheel', 'Cython>=3', "poetry-core>=1.0.0"]
31 build-backend = "poetry.core.masonry.api"
32
33 [tool.ruff]