diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2023-12-18 19:09:00 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-18 22:17:25 -0800 |
commit | 1d887eede793e8e3da3a75f3ffead7ea1d867698 (patch) | |
tree | fdad1d19475ba894197e093955f6be6515475e92 /meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch | |
parent | c6ba2fcc4a46cf8df0060d1dc90d4b6864cb6140 (diff) | |
download | meta-openembedded-1d887eede793e8e3da3a75f3ffead7ea1d867698.tar.gz |
python3-dominate: upgrade 2.8.0 -> 2.9.0
Upgrade to version 2.9.0:
- Modernize setuptools support to use pyproject.toml
- Remove brittle test
Remove fix-ptests.patch as the issue has been solved upstream.
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch | 20 |
1 files changed, 0 insertions, 20 deletions
diff --git a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch b/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch deleted file mode 100644 index 81211d4498..0000000000 --- a/meta-python/recipes-devtools/python/python3-dominate/fix-ptests.patch +++ /dev/null | |||
@@ -1,20 +0,0 @@ | |||
1 | Fixes test failures on musl | ||
2 | |||
3 | Fixes errors | ||
4 | ptestresult.python3-dominate.tests/test_dom_tag.py::test___get_thread_context | ||
5 | |||
6 | Upstream-Status: Pending | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | |||
9 | diff --git a/tests/test_dom_tag.py b/tests/test_dom_tag.py | ||
10 | index 43ffecb..1126e54 100644 | ||
11 | --- a/tests/test_dom_tag.py | ||
12 | +++ b/tests/test_dom_tag.py | ||
13 | @@ -18,6 +18,7 @@ def test___get_thread_context(monkeypatch): | ||
14 | monkeypatch.setattr(sut, 'threading', threading) | ||
15 | |||
16 | assert sut._get_thread_context() in [ | ||
17 | + 1692341442, # Python >= 3.9, 32-bit | ||
18 | -6805948436281256182, # Python >= 3.9 | ||
19 | 3713141171098444831, # Python < 3.9 | ||
20 | ] | ||