summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-elementpath_4.7.0.bb
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-12-24 17:26:14 +0800
committerKhem Raj <raj.khem@gmail.com>2024-12-24 08:23:08 -0800
commitc2bc74aec5d6f2e8f1f949f17fb61fbba464689c (patch)
treee49bf2fccdc2bc6ab23033d1d464c48883bb99fb /meta-python/recipes-devtools/python/python3-elementpath_4.7.0.bb
parent7eafc62373202ad3132ff7b4eb8f90af70832e77 (diff)
downloadmeta-openembedded-c2bc74aec5d6f2e8f1f949f17fb61fbba464689c.tar.gz
python3-elementpath: upgrade 4.6.0 -> 4.7.0
Changelog: ========== - Fix fragment argument usage - Fix constructors nud() to skip argument check with XP31+ arrow operator Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-elementpath_4.7.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-elementpath_4.7.0.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-elementpath_4.7.0.bb b/meta-python/recipes-devtools/python/python3-elementpath_4.7.0.bb
new file mode 100644
index 0000000000..2a9eb43b5e
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-elementpath_4.7.0.bb
@@ -0,0 +1,19 @@
1DESCRIPTION = "Provide XPath 1.0 and 2.0 selectors for Python's ElementTree XML data structures, both for the standard ElementTree library and for the lxml.etree library."
2HOMEPAGE = "https://github.com/sissaschool/elementpath"
3LICENSE = "MIT"
4LIC_FILES_CHKSUM = "file://LICENSE;md5=5dbb7fb7d72da3921202dd7b995d3ecf"
5
6SRC_URI[sha256sum] = "a2029dc8752fcfec49663d1ed1b412c6daf278c0c91938f50f63c4fe9ed1848e"
7
8PYPI_PACKAGE = "elementpath"
9inherit pypi setuptools3
10
11RDEPENDS:${PN} += " \
12 python3-xml \
13 python3-core \
14 python3-numbers \
15 python3-datetime \
16 python3-stringold \
17"
18
19BBCLASSEXTEND = "native nativesdk"