diff options
author | Alistair Francis <alistair.francis@wdc.com> | 2019-04-05 14:41:52 +0000 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2019-04-06 08:22:22 -0700 |
commit | 5206fbd7762371d35cd9abfa7fe6e3ef355cddf8 (patch) | |
tree | e8526052fb20ed44c104d5224e42c25dc67a2df5 /meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch | |
parent | c32f3f581a4c9587dc114f0a92c474898d3dc9a7 (diff) | |
download | meta-openembedded-5206fbd7762371d35cd9abfa7fe6e3ef355cddf8.tar.gz |
python3-pyfann2: Initial commit
Signed-off-by: Alistair Francis <alistair.francis@wdc.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch | 28 |
1 files changed, 28 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch b/meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch new file mode 100644 index 0000000000..cbc838f0e2 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-fann2/0001-setup.py-Don-t-hardcode-swig-and-fann2-binary-locati.patch | |||
@@ -0,0 +1,28 @@ | |||
1 | From 85307f592c7cb87af162cca4b121b874108b7754 Mon Sep 17 00:00:00 2001 | ||
2 | From: Alistair Francis <alistair.francis@wdc.com> | ||
3 | Date: Tue, 2 Apr 2019 11:25:15 -0700 | ||
4 | Subject: [PATCH] setup.py: Don't hardcode swig and fann2 binary locations | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | Signed-off-by: Alistair Francis <alistair.francis@wdc.com> | ||
8 | --- | ||
9 | setup.py | 5 +---- | ||
10 | 1 file changed, 1 insertion(+), 4 deletions(-) | ||
11 | |||
12 | diff --git a/setup.py b/setup.py | ||
13 | index 37af7c7..8e416f2 100755 | ||
14 | --- a/setup.py | ||
15 | +++ b/setup.py | ||
16 | @@ -81,11 +81,8 @@ def find_swig(): | ||
17 | |||
18 | def build_swig(): | ||
19 | '''Run SWIG with specified parameters''' | ||
20 | - print("Looking for FANN libs...") | ||
21 | - find_fann() | ||
22 | - print("running SWIG...") | ||
23 | swig_bin = find_swig() | ||
24 | - swig_cmd = [swig_bin, '-c++', '-python', 'fann2/fann2.i'] | ||
25 | + swig_cmd = ['swig', '-c++', '-python', 'fann2/fann2.i'] | ||
26 | subprocess.Popen(swig_cmd).wait() | ||
27 | |||
28 | if "sdist" not in sys.argv: | ||