diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-12-14 16:51:40 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-14 07:53:23 -0800 |
commit | eaa7d950ed3bd848bc65ca57d92ae073f679b22d (patch) | |
tree | 70247f591244effdff375b9f5271662a4211a272 /meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb | |
parent | 532ba5518af7b310549784931bcd7d45ae0dbe35 (diff) | |
download | meta-openembedded-eaa7d950ed3bd848bc65ca57d92ae073f679b22d.tar.gz |
python3-flask-restx: upgrade 1.2.0 -> 1.3.0
Changelog:
============
* Fixing werkzeug 3 deprecated version import. Import is replaced by new style version check with importlib
* Fixing flask 3.0+ compatibility of 'ModuleNotFoundError: No module named 'flask.scaffold'' Import error.
* Fix wrong status code and message on responses when handling 'HTTPExceptions'
* Add flask 2 and flask 3 to testing matrix.
* Update internally pinned pytest-flask to 1.3.0 for Flask >=3.0.0 support.
* Python 3.12 support.
* Fix wrong status code and message on responses when handling HTTPExceptions.
* Update changelog Flask version table.
* Remove temporary package version restrictions for flask < 3.0.0, werkzeug and jsonschema
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb | 13 |
1 files changed, 13 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb b/meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb new file mode 100644 index 0000000000..9c2a1e9a8b --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-flask-restx_1.3.0.bb | |||
@@ -0,0 +1,13 @@ | |||
1 | DESCRIPTION = "Fully featured framework for fast, easy and documented API development with Flask" | ||
2 | LICENSE = "BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://LICENSE;md5=c96dd911c6d9e32868b6bc667a38a3e2" | ||
4 | |||
5 | SRC_URI[sha256sum] = "4f3d3fa7b6191fcc715b18c201a12cd875176f92ba4acc61626ccfd571ee1728" | ||
6 | |||
7 | inherit pypi setuptools3 | ||
8 | |||
9 | RDEPENDS:${PN} += " \ | ||
10 | python3-aniso8601 \ | ||
11 | python3-jsonschema \ | ||
12 | python3-pytz \ | ||
13 | " | ||