summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-flask-socketio_4.3.1.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-08-26 18:40:20 +0300
committerKhem Raj <raj.khem@gmail.com>2020-08-31 08:26:13 -0700
commitbfa20dbf2bc7d62adfa6729f77d09d4821e18e33 (patch)
treebf6f30c36fd7fff6d7cf3bae5cbcc907a1ebed1e /meta-python/recipes-devtools/python/python3-flask-socketio_4.3.1.bb
parentc32d2eb448ce343463dc75cc6120f395e32f0177 (diff)
downloadmeta-openembedded-bfa20dbf2bc7d62adfa6729f77d09d4821e18e33.tar.gz
python3-flask-socketio: Upgrade 4.2.1 -> 4.3.1
Upgrade to release 4.3.1: - Fix is_connected in test client - Handle callbacks for emits outside of request context - Improve test client unit test to use two concurrent clients - Accept skip_sid argument in emit - Fix is_connected() method in test client - Log warning when gevent is used but WebSocket is missing - More accurate logging documentation Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask-socketio_4.3.1.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-flask-socketio_4.3.1.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask-socketio_4.3.1.bb b/meta-python/recipes-devtools/python/python3-flask-socketio_4.3.1.bb
new file mode 100644
index 0000000000..b8631bf50a
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-flask-socketio_4.3.1.bb
@@ -0,0 +1,18 @@
1SUMMARY = "Socket.IO integration for Flask applications"
2HOMEPAGE = "https://github.com/miguelgrinberg/Flask-SocketIO/"
3SECTION = "devel/python"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=38cc21254909604298ce763a6e4440a0"
7
8inherit pypi setuptools3
9
10PYPI_PACKAGE = "Flask-SocketIO"
11
12SRC_URI[md5sum] = "d7992b0b4aaf473b7eff21fc14e8d1b2"
13SRC_URI[sha256sum] = "36c1d5765010d1f4e4f05b4cc9c20c289d9dc70698c88d1addd0afcfedc5b062"
14
15RDEPENDS_${PN} += "\
16 ${PYTHON_PN}-flask \
17 ${PYTHON_PN}-socketio \
18 "