diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2024-01-02 15:08:15 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-01-02 00:35:52 -0800 |
commit | a50b58f6268dc20cccf78f2586dccbb11f907ce7 (patch) | |
tree | 4f2927a1321258aaac4e177c667a06ec747d0f97 /meta-python/recipes-devtools/python/python3-flask_3.0.0.bb | |
parent | e17de9ffb93b97ab9a8d069b402133dabe0e5a99 (diff) | |
download | meta-openembedded-a50b58f6268dc20cccf78f2586dccbb11f907ce7.tar.gz |
python3-flask: upgrade 2.3.3 -> 3.0.0
Changelog:
============
-Remove previously deprecated code.
-Deprecate the __version__ attribute. Use feature detection,
or importlib.metadata.version("flask"), instead.
-Restructure the code such that the Flask (app) and Blueprint classes have
Sans-IO bases.
-Allow self as an argument to url_for.
-Require Werkzeug >= 3.0.0.
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-flask_3.0.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-flask_3.0.0.bb | 25 |
1 files changed, 25 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb b/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb new file mode 100644 index 0000000000..e0afd3718f --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-flask_3.0.0.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | SUMMARY = "A microframework based on Werkzeug, Jinja2 and good intentions" | ||
2 | DESCRIPTION = "\ | ||
3 | Flask is a microframework for Python based on Werkzeug, Jinja 2 and good \ | ||
4 | intentions. And before you ask: It’s BSD licensed!" | ||
5 | HOMEPAGE = "https://github.com/mitsuhiko/flask/" | ||
6 | LICENSE = "BSD-3-Clause" | ||
7 | LIC_FILES_CHKSUM = "file://LICENSE.rst;md5=ffeffa59c90c9c4a033c7574f8f3fb75" | ||
8 | |||
9 | SRC_URI[sha256sum] = "cfadcdb638b609361d29ec22360d6070a77d7463dcb3ab08d2c2f2f168845f58" | ||
10 | |||
11 | UPSTREAM_CHECK_URI = "https://pypi.python.org/pypi/Flask" | ||
12 | UPSTREAM_CHECK_REGEX = "/Flask/(?P<pver>(\d+[\.\-_]*)+)" | ||
13 | |||
14 | inherit pypi python_setuptools_build_meta | ||
15 | |||
16 | CLEANBROKEN = "1" | ||
17 | |||
18 | RDEPENDS:${PN} = " \ | ||
19 | ${PYTHON_PN}-blinker \ | ||
20 | ${PYTHON_PN}-click \ | ||
21 | ${PYTHON_PN}-itsdangerous \ | ||
22 | ${PYTHON_PN}-jinja2 \ | ||
23 | ${PYTHON_PN}-profile \ | ||
24 | ${PYTHON_PN}-werkzeug \ | ||
25 | " | ||