summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
diff options
context:
space:
mode:
authorJustin Bronder <jsbronder@cold-front.org>2022-03-01 11:54:18 -0500
committerKhem Raj <raj.khem@gmail.com>2022-03-03 08:48:06 -0800
commitad10b550727e03a04585754e32c184d17d9d2ea9 (patch)
tree3d629a2f36d8754b2faeec8fd3418bb76eb00829 /meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
parent4771d7f886013917d7f4cb593b4f4c32109b4452 (diff)
downloadmeta-openembedded-ad10b550727e03a04585754e32c184d17d9d2ea9.tar.gz
python3-gcovr: fix wheel build
Recipe does not inherit pypi nor would PN be a good guess at the name of the wheel. Set PIP_INSTALL_PACKAGE appropriately. Signed-off-by: Justin Bronder <jsbronder@cold-front.org> Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-gcovr_5.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-gcovr_5.0.bb1
1 files changed, 1 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
index 330831a0b3..27ae198139 100644
--- a/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
+++ b/meta-python/recipes-devtools/python/python3-gcovr_5.0.bb
@@ -10,6 +10,7 @@ SRCREV = "2b50284e8a6792b4ddcba14e2050c5c05f15deb6"
10S = "${WORKDIR}/git" 10S = "${WORKDIR}/git"
11 11
12inherit setuptools3 12inherit setuptools3
13PIP_INSTALL_PACKAGE = "gcovr"
13 14
14RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments" 15RDEPENDS:${PN} += "${PYTHON_PN}-jinja2 ${PYTHON_PN}-lxml ${PYTHON_PN}-setuptools ${PYTHON_PN}-pygments"
15 16