diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2024-10-16 21:34:56 +0200 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2024-10-16 14:07:29 -0700 |
commit | 5122ca2d5cc890d317fb185b1b2c7d2011fecd15 (patch) | |
tree | d189c2a3b41fd23802189fb1c3f60dff9ba4d44a /meta-python/recipes-devtools/python/python3-geojson/py3.13.patch | |
parent | a426f5efdc7f91ec800d79a5b28c5e2431357b01 (diff) | |
download | meta-openembedded-5122ca2d5cc890d317fb185b1b2c7d2011fecd15.tar.gz |
python3-geojson: backport python 3.13 patch
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-geojson/py3.13.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-geojson/py3.13.patch | 38 |
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-geojson/py3.13.patch b/meta-python/recipes-devtools/python/python3-geojson/py3.13.patch new file mode 100644 index 0000000000..45618fa6dd --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-geojson/py3.13.patch | |||
@@ -0,0 +1,38 @@ | |||
1 | From c13afff339e6b78f442785cc95f0eb66ddab3e7b Mon Sep 17 00:00:00 2001 | ||
2 | From: Bas Couwenberg <sebastic@xs4all.nl> | ||
3 | Date: Fri, 4 Oct 2024 16:18:34 +0200 | ||
4 | Subject: [PATCH] Don't fail with Python 3.13. (#228) | ||
5 | |||
6 | Upstream-Status: Backport [https://github.com/jazzband/geojson/commit/c13afff339e6b78f442785cc95f0eb66ddab3e7b] | ||
7 | Signed-off-by: Alexander Kanavin <alex@linutronix.de> | ||
8 | --- | ||
9 | .github/workflows/test.yml | 2 +- | ||
10 | README.rst | 2 +- | ||
11 | setup.py | 5 +++-- | ||
12 | tox.ini | 2 +- | ||
13 | 4 files changed, 6 insertions(+), 5 deletions(-) | ||
14 | |||
15 | diff --git a/setup.py b/setup.py | ||
16 | index 95b2823..004d3eb 100644 | ||
17 | --- a/setup.py | ||
18 | +++ b/setup.py | ||
19 | @@ -17,8 +17,8 @@ | ||
20 | |||
21 | |||
22 | major_version, minor_version = sys.version_info[:2] | ||
23 | -if not (major_version == 3 and 7 <= minor_version <= 12): | ||
24 | - sys.stderr.write("Sorry, only Python 3.7 - 3.12 are " | ||
25 | +if not (major_version == 3 and 7 <= minor_version <= 13): | ||
26 | + sys.stderr.write("Sorry, only Python 3.7 - 3.13 are " | ||
27 | "supported at this time.\n") | ||
28 | exit(1) | ||
29 | |||
30 | @@ -53,6 +53,7 @@ | ||
31 | "Programming Language :: Python :: 3.10", | ||
32 | "Programming Language :: Python :: 3.11", | ||
33 | "Programming Language :: Python :: 3.12", | ||
34 | + "Programming Language :: Python :: 3.13", | ||
35 | "Topic :: Scientific/Engineering :: GIS", | ||
36 | ] | ||
37 | ) | ||
38 | |||