summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-geojson/py3.13.patch
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-12-24 17:26:20 +0800
committerKhem Raj <raj.khem@gmail.com>2024-12-24 08:23:08 -0800
commitb7ea9a163ded2ca4ff098d7f6ad2038b791487b9 (patch)
tree08b4a647627f8276af707142842f5283a8d4fe87 /meta-python/recipes-devtools/python/python3-geojson/py3.13.patch
parent48bee5e6f7e37bb296580e8f9b701326675059bf (diff)
downloadmeta-openembedded-b7ea9a163ded2ca4ff098d7f6ad2038b791487b9.tar.gz
python3-geojson: upgrade 3.1.0 -> 3.2.0
py3.13.patch removed since it's included in 3.2.0 Changelog: ========== - Add support for Python 3.13 - Code modernization - RtD bugfix Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-geojson/py3.13.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-geojson/py3.13.patch38
1 files changed, 0 insertions, 38 deletions
diff --git a/meta-python/recipes-devtools/python/python3-geojson/py3.13.patch b/meta-python/recipes-devtools/python/python3-geojson/py3.13.patch
deleted file mode 100644
index 45618fa6dd..0000000000
--- a/meta-python/recipes-devtools/python/python3-geojson/py3.13.patch
+++ /dev/null
@@ -1,38 +0,0 @@
1From c13afff339e6b78f442785cc95f0eb66ddab3e7b Mon Sep 17 00:00:00 2001
2From: Bas Couwenberg <sebastic@xs4all.nl>
3Date: Fri, 4 Oct 2024 16:18:34 +0200
4Subject: [PATCH] Don't fail with Python 3.13. (#228)
5
6Upstream-Status: Backport [https://github.com/jazzband/geojson/commit/c13afff339e6b78f442785cc95f0eb66ddab3e7b]
7Signed-off-by: Alexander Kanavin <alex@linutronix.de>
8---
9 .github/workflows/test.yml | 2 +-
10 README.rst | 2 +-
11 setup.py | 5 +++--
12 tox.ini | 2 +-
13 4 files changed, 6 insertions(+), 5 deletions(-)
14
15diff --git a/setup.py b/setup.py
16index 95b2823..004d3eb 100644
17--- a/setup.py
18+++ b/setup.py
19@@ -17,8 +17,8 @@
20
21
22 major_version, minor_version = sys.version_info[:2]
23-if not (major_version == 3 and 7 <= minor_version <= 12):
24- sys.stderr.write("Sorry, only Python 3.7 - 3.12 are "
25+if not (major_version == 3 and 7 <= minor_version <= 13):
26+ sys.stderr.write("Sorry, only Python 3.7 - 3.13 are "
27 "supported at this time.\n")
28 exit(1)
29
30@@ -53,6 +53,7 @@
31 "Programming Language :: Python :: 3.10",
32 "Programming Language :: Python :: 3.11",
33 "Programming Language :: Python :: 3.12",
34+ "Programming Language :: Python :: 3.13",
35 "Topic :: Scientific/Engineering :: GIS",
36 ]
37 )
38