summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
diff options
context:
space:
mode:
authorWang Mingyu <wangmy@fujitsu.com>2024-11-06 14:30:39 +0800
committerKhem Raj <raj.khem@gmail.com>2024-11-05 22:45:19 -0800
commit8318a3d490b25a1a85b33f3f632e7dd655f1f9db (patch)
tree209b26487e143f14cdf43ab7a9976c5080db1c35 /meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
parent26f90e96cc016c1ef72120f8edf72ebbd44e9c17 (diff)
downloadmeta-openembedded-8318a3d490b25a1a85b33f3f632e7dd655f1f9db.tar.gz
python3-grpcio-tools: upgrade 1.66.2 -> 1.67.1
0001-protobuf-Disable-musttail-attribute-on-mips.patch 0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch refreshed for 1.67.1 Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch15
1 files changed, 6 insertions, 9 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 07276c17f6..5366a1e1cf 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio-tools/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -1,4 +1,4 @@
1From 9b2f1d400db8b8d0045f5a58a748a2dc52b5c9ef Mon Sep 17 00:00:00 2001 1From f1bf68aaa5417bcb7ad4996f1be8d2c0f53c521c Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com> 2From: Khem Raj <raj.khem@gmail.com>
3Date: Wed, 17 Feb 2021 13:38:55 -0800 3Date: Wed, 17 Feb 2021 13:38:55 -0800
4Subject: [PATCH] setup.py: Do not mix C and C++ compiler options 4Subject: [PATCH] setup.py: Do not mix C and C++ compiler options
@@ -23,14 +23,14 @@ Upstream-Status: Inappropriate [oe specific]
23 23
24Signed-off-by: Khem Raj <raj.khem@gmail.com> 24Signed-off-by: Khem Raj <raj.khem@gmail.com>
25--- 25---
26 setup.py | 9 ++++++--- 26 setup.py | 10 ++++++----
27 1 file changed, 6 insertions(+), 3 deletions(-) 27 1 file changed, 6 insertions(+), 4 deletions(-)
28 28
29diff --git a/setup.py b/setup.py 29diff --git a/setup.py b/setup.py
30index cc53e79..be3bc78 100644 30index 5e19b63..61b30d8 100644
31--- a/setup.py 31--- a/setup.py
32+++ b/setup.py 32+++ b/setup.py
33@@ -88,9 +88,11 @@ 33@@ -90,9 +90,11 @@ def check_linker_need_libatomic():
34 b"#include <atomic>\n" 34 b"#include <atomic>\n"
35 + b"int main() { return std::atomic<int64_t>{}; }" 35 + b"int main() { return std::atomic<int64_t>{}; }"
36 ) 36 )
@@ -45,7 +45,7 @@ index cc53e79..be3bc78 100644
45 stdin=PIPE, 45 stdin=PIPE,
46 stdout=PIPE, 46 stdout=PIPE,
47 stderr=PIPE, 47 stderr=PIPE,
48@@ -101,7 +103,7 @@ 48@@ -103,7 +105,7 @@ def check_linker_need_libatomic():
49 # Double-check to see if -latomic actually can solve the problem. 49 # Double-check to see if -latomic actually can solve the problem.
50 # https://github.com/grpc/grpc/issues/22491 50 # https://github.com/grpc/grpc/issues/22491
51 cpp_test = subprocess.Popen( 51 cpp_test = subprocess.Popen(
@@ -54,6 +54,3 @@ index cc53e79..be3bc78 100644
54 stdin=PIPE, 54 stdin=PIPE,
55 stdout=PIPE, 55 stdout=PIPE,
56 stderr=PIPE, 56 stderr=PIPE,
57--
582.25.1
59