summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2023-07-04 17:00:24 -0700
committerKhem Raj <raj.khem@gmail.com>2023-07-07 09:00:59 -0700
commit1b58a4e64f21e7f80f9ec7d8360af506da0df578 (patch)
treef4dbf421d3464cef3e8edfc6f7737382be313432 /meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
parent01b51cff3bbee4b4801f82f74d3b5b097aa0146e (diff)
downloadmeta-openembedded-1b58a4e64f21e7f80f9ec7d8360af506da0df578.tar.gz
python3-grpcio: Upgrade to 1.56.0
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch16
1 files changed, 5 insertions, 11 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 1f465dbb6e..13911ddcf3 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -29,11 +29,9 @@ Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
29 src/python/grpcio/commands.py | 5 ++++- 29 src/python/grpcio/commands.py | 5 ++++-
30 2 files changed, 11 insertions(+), 5 deletions(-) 30 2 files changed, 11 insertions(+), 5 deletions(-)
31 31
32diff --git a/setup.py b/setup.py
33index 3a50c97..bb2386d 100644
34--- a/setup.py 32--- a/setup.py
35+++ b/setup.py 33+++ b/setup.py
36@@ -205,8 +205,11 @@ def check_linker_need_libatomic(): 34@@ -206,8 +206,11 @@ def check_linker_need_libatomic():
37 """Test if linker on system needs libatomic.""" 35 """Test if linker on system needs libatomic."""
38 code_test = (b'#include <atomic>\n' + 36 code_test = (b'#include <atomic>\n' +
39 b'int main() { return std::atomic<int64_t>{}; }') 37 b'int main() { return std::atomic<int64_t>{}; }')
@@ -47,7 +45,7 @@ index 3a50c97..bb2386d 100644
47 stdin=PIPE, 45 stdin=PIPE,
48 stdout=PIPE, 46 stdout=PIPE,
49 stderr=PIPE) 47 stderr=PIPE)
50@@ -215,8 +218,8 @@ def check_linker_need_libatomic(): 48@@ -216,8 +219,8 @@ def check_linker_need_libatomic():
51 return False 49 return False
52 # Double-check to see if -latomic actually can solve the problem. 50 # Double-check to see if -latomic actually can solve the problem.
53 # https://github.com/grpc/grpc/issues/22491 51 # https://github.com/grpc/grpc/issues/22491
@@ -58,15 +56,14 @@ index 3a50c97..bb2386d 100644
58 stdin=PIPE, 56 stdin=PIPE,
59 stdout=PIPE, 57 stdout=PIPE,
60 stderr=PIPE) 58 stderr=PIPE)
61diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py
62index d93b6c7..a8c4a51 100644
63--- a/src/python/grpcio/commands.py 59--- a/src/python/grpcio/commands.py
64+++ b/src/python/grpcio/commands.py 60+++ b/src/python/grpcio/commands.py
65@@ -228,7 +228,10 @@ class BuildExt(build_ext.build_ext): 61@@ -228,8 +228,10 @@ class BuildExt(build_ext.build_ext):
66 """ 62 """
67 try: 63 try:
68 # TODO(lidiz) Remove the generated a.out for success tests. 64 # TODO(lidiz) Remove the generated a.out for success tests.
69- cc_test = subprocess.Popen(['cc', '-x', 'c', '-std=c++14', '-'], 65- cc = os.environ.get('CC', 'cc')
66- cc_test = subprocess.Popen([cc, '-x', 'c', '-std=c++14', '-'],
70+ cc_test, cc_args = os.environ.get('CC').split(' ', 1) or 'gcc' 67+ cc_test, cc_args = os.environ.get('CC').split(' ', 1) or 'gcc'
71+ if not cc_args: 68+ if not cc_args:
72+ cc_args = "-g" 69+ cc_args = "-g"
@@ -74,6 +71,3 @@ index d93b6c7..a8c4a51 100644
74 stdin=subprocess.PIPE, 71 stdin=subprocess.PIPE,
75 stdout=subprocess.PIPE, 72 stdout=subprocess.PIPE,
76 stderr=subprocess.PIPE) 73 stderr=subprocess.PIPE)
77--
782.25.1
79