summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2022-03-15 09:18:24 -0700
committertgamblin <trevor.gamblin@windriver.com>2022-03-15 15:34:22 -0400
commitb9936f62abf48097edd231878c7137aeaa39518f (patch)
treef9360ff617c61a85637e9637f31a4f959978b555 /meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
parentf5a978bb7ed047537eb98306cf87704983907693 (diff)
downloadmeta-openembedded-b9936f62abf48097edd231878c7137aeaa39518f.tar.gz
python3-grpcio, python3-grpcio-tools: Upgrade to 1.44.0
- Fix build on ppc64le/musl - Add patch to fix abseil on ppc64 - Changes are here [1] [1] https://github.com/grpc/grpc/releases/tag/v1.44.0 Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: tgamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch17
1 files changed, 5 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
index 373669461b..febe6c4c87 100644
--- a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
+++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
@@ -28,11 +28,9 @@ Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
28 src/python/grpcio/commands.py | 5 ++++- 28 src/python/grpcio/commands.py | 5 ++++-
29 2 files changed, 10 insertions(+), 4 deletions(-) 29 2 files changed, 10 insertions(+), 4 deletions(-)
30 30
31diff --git a/setup.py b/setup.py
32index 4b8c9d4..271b7b1 100644
33--- a/setup.py 31--- a/setup.py
34+++ b/setup.py 32+++ b/setup.py
35@@ -172,8 +172,11 @@ def check_linker_need_libatomic(): 33@@ -199,8 +199,11 @@ def check_linker_need_libatomic():
36 """Test if linker on system needs libatomic.""" 34 """Test if linker on system needs libatomic."""
37 code_test = (b'#include <atomic>\n' + 35 code_test = (b'#include <atomic>\n' +
38 b'int main() { return std::atomic<int64_t>{}; }') 36 b'int main() { return std::atomic<int64_t>{}; }')
@@ -46,20 +44,18 @@ index 4b8c9d4..271b7b1 100644
46 stdin=PIPE, 44 stdin=PIPE,
47 stdout=PIPE, 45 stdout=PIPE,
48 stderr=PIPE) 46 stderr=PIPE)
49@@ -183,7 +186,7 @@ def check_linker_need_libatomic(): 47@@ -210,7 +213,7 @@ def check_linker_need_libatomic():
50 # Double-check to see if -latomic actually can solve the problem. 48 # Double-check to see if -latomic actually can solve the problem.
51 # https://github.com/grpc/grpc/issues/22491 49 # https://github.com/grpc/grpc/issues/22491
52 cpp_test = subprocess.Popen( 50 cpp_test = subprocess.Popen(
53- [cxx, '-x', 'c++', '-std=c++11', '-latomic', '-'], 51- [cxx, '-x', 'c++', '-std=c++11', '-', '-latomic'],
54+ [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-latomic', '-'], 52+ [cxx, cxx_args, '-x', 'c++', '-std=c++11', '-', '-latomic'],
55 stdin=PIPE, 53 stdin=PIPE,
56 stdout=PIPE, 54 stdout=PIPE,
57 stderr=PIPE) 55 stderr=PIPE)
58diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py
59index a8b2ff5..b928201 100644
60--- a/src/python/grpcio/commands.py 56--- a/src/python/grpcio/commands.py
61+++ b/src/python/grpcio/commands.py 57+++ b/src/python/grpcio/commands.py
62@@ -219,7 +219,10 @@ class BuildExt(build_ext.build_ext): 58@@ -228,7 +228,10 @@ class BuildExt(build_ext.build_ext):
63 """ 59 """
64 try: 60 try:
65 # TODO(lidiz) Remove the generated a.out for success tests. 61 # TODO(lidiz) Remove the generated a.out for success tests.
@@ -71,6 +67,3 @@ index a8b2ff5..b928201 100644
71 stdin=subprocess.PIPE, 67 stdin=subprocess.PIPE,
72 stdout=subprocess.PIPE, 68 stdout=subprocess.PIPE,
73 stderr=subprocess.PIPE) 69 stderr=subprocess.PIPE)
74--
752.30.1
76