diff options
author | wangmy <wangmy@fujitsu.com> | 2022-09-20 10:22:45 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2022-09-21 06:34:45 -0700 |
commit | c5533c184eda62311b7998f61c937df2a5dd2390 (patch) | |
tree | ab84ace2cd011b9efb7125f66a07352fe05e15e4 /meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |
parent | bb27cf1c1e92bfa6aeff7e339ff09db37a4b1bd6 (diff) | |
download | meta-openembedded-c5533c184eda62311b7998f61c937df2a5dd2390.tar.gz |
python3-grpcio: upgrade 1.48.1 -> 1.49.0
0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch
refreshed for new version.
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 27 |
1 files changed, 15 insertions, 12 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch index f416ca2728..1f465dbb6e 100644 --- a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |||
@@ -23,16 +23,17 @@ Upstream-Status: Inappropriate [oe specific] | |||
23 | 23 | ||
24 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | 24 | Signed-off-by: Khem Raj <raj.khem@gmail.com> |
25 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | 25 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> |
26 | Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> | ||
26 | --- | 27 | --- |
27 | setup.py | 9 ++++++--- | 28 | setup.py | 11 +++++++---- |
28 | src/python/grpcio/commands.py | 5 ++++- | 29 | src/python/grpcio/commands.py | 5 ++++- |
29 | 2 files changed, 10 insertions(+), 4 deletions(-) | 30 | 2 files changed, 11 insertions(+), 5 deletions(-) |
30 | 31 | ||
31 | diff --git a/setup.py b/setup.py | 32 | diff --git a/setup.py b/setup.py |
32 | index ec27fe4..b2d2d1a 100644 | 33 | index 3a50c97..bb2386d 100644 |
33 | --- a/setup.py | 34 | --- a/setup.py |
34 | +++ b/setup.py | 35 | +++ b/setup.py |
35 | @@ -206,8 +206,11 @@ def check_linker_need_libatomic(): | 36 | @@ -205,8 +205,11 @@ def check_linker_need_libatomic(): |
36 | """Test if linker on system needs libatomic.""" | 37 | """Test if linker on system needs libatomic.""" |
37 | code_test = (b'#include <atomic>\n' + | 38 | code_test = (b'#include <atomic>\n' + |
38 | b'int main() { return std::atomic<int64_t>{}; }') | 39 | b'int main() { return std::atomic<int64_t>{}; }') |
@@ -46,15 +47,17 @@ index ec27fe4..b2d2d1a 100644 | |||
46 | stdin=PIPE, | 47 | stdin=PIPE, |
47 | stdout=PIPE, | 48 | stdout=PIPE, |
48 | stderr=PIPE) | 49 | stderr=PIPE) |
49 | @@ -217,7 +220,7 @@ def check_linker_need_libatomic(): | 50 | @@ -215,8 +218,8 @@ def check_linker_need_libatomic(): |
51 | return False | ||
50 | # Double-check to see if -latomic actually can solve the problem. | 52 | # Double-check to see if -latomic actually can solve the problem. |
51 | # https://github.com/grpc/grpc/issues/22491 | 53 | # https://github.com/grpc/grpc/issues/22491 |
52 | cpp_test = subprocess.Popen( | 54 | - cpp_test = subprocess.Popen(cxx + |
53 | - [cxx, '-x', 'c++', '-std=c++14', '-', '-latomic'], | 55 | - ['-x', 'c++', '-std=c++14', '-', '-latomic'], |
54 | + [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'], | 56 | + cpp_test = subprocess.Popen( |
55 | stdin=PIPE, | 57 | + [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'], |
56 | stdout=PIPE, | 58 | stdin=PIPE, |
57 | stderr=PIPE) | 59 | stdout=PIPE, |
60 | stderr=PIPE) | ||
58 | diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py | 61 | diff --git a/src/python/grpcio/commands.py b/src/python/grpcio/commands.py |
59 | index d93b6c7..a8c4a51 100644 | 62 | index d93b6c7..a8c4a51 100644 |
60 | --- a/src/python/grpcio/commands.py | 63 | --- a/src/python/grpcio/commands.py |