diff options
author | Alexander Kanavin <alex.kanavin@gmail.com> | 2023-12-15 08:52:35 +0100 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-12-18 22:17:21 -0800 |
commit | d595b18e4691967fb5b699e9272f916d769a28d7 (patch) | |
tree | b3f3d2fafb6f8cfb6e8166129dc4161c7c6e95a5 /meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | |
parent | a293a7128af89a7cace861333b13387bccbf5de2 (diff) | |
download | meta-openembedded-d595b18e4691967fb5b699e9272f916d769a28d7.tar.gz |
python3-grpcio: update 1.56.2 -> 1.59.3
This is needed for python 3.12 compatibility.
Drop 0001-direct_mmap-Use-off_t-on-linux.patch as
issue resolved upstream.
Other dropped patches are all due to the code being significantly refactored upstream;
if the issues persist, please write updated patches.
Signed-off-by: Alexander Kanavin <alex@linutronix.de>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch | 73 |
1 files changed, 0 insertions, 73 deletions
diff --git a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch b/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch deleted file mode 100644 index 13911ddcf3..0000000000 --- a/meta-python/recipes-devtools/python/python3-grpcio/0001-setup.py-Do-not-mix-C-and-C-compiler-options.patch +++ /dev/null | |||
@@ -1,73 +0,0 @@ | |||
1 | From de10fbc2386dcac3ab810c49b6977b2ee01bf426 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Wed, 17 Feb 2021 13:30:23 -0800 | ||
4 | Subject: [PATCH] setup.py: Do not mix C and C++ compiler options | ||
5 | |||
6 | EXTRA_ENV_COMPILE_ARGS is used both with CC and CXX | ||
7 | so using -std=c++11 or -std=gnu99 together will cause | ||
8 | build time errors espcially with clang | ||
9 | |||
10 | Keep '-std=c++11' to fix native build error | ||
11 | with old gcc (such as gcc 5.4.0 on ubuntu 16.04), for clang | ||
12 | we will remove them through GRPC_PYTHON_CFLAGS at do_compile | ||
13 | in bb recipe. | ||
14 | |||
15 | While export CC="gcc ", cc_args is None, it will | ||
16 | cause subprocess.Popen always return 1. On centos 8, if you don't | ||
17 | install package libatomic, there will be a native build error | ||
18 | `cannot find /usr/lib64/libatomic.so.1.2.0'. | ||
19 | |||
20 | Add no harm '-g' to cc_args if cc_args is empty. | ||
21 | |||
22 | Upstream-Status: Inappropriate [oe specific] | ||
23 | |||
24 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
25 | Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> | ||
26 | Signed-off-by: Wang Mingyu <wangmy@fujitsu.com> | ||
27 | --- | ||
28 | setup.py | 11 +++++++---- | ||
29 | src/python/grpcio/commands.py | 5 ++++- | ||
30 | 2 files changed, 11 insertions(+), 5 deletions(-) | ||
31 | |||
32 | --- a/setup.py | ||
33 | +++ b/setup.py | ||
34 | @@ -206,8 +206,11 @@ def check_linker_need_libatomic(): | ||
35 | """Test if linker on system needs libatomic.""" | ||
36 | code_test = (b'#include <atomic>\n' + | ||
37 | b'int main() { return std::atomic<int64_t>{}; }') | ||
38 | - cxx = shlex.split(os.environ.get('CXX', 'c++')) | ||
39 | - cpp_test = subprocess.Popen(cxx + ['-x', 'c++', '-std=c++14', '-'], | ||
40 | + cxx, cxx_args = os.environ.get('CXX').split(' ', 1) or 'c++' | ||
41 | + if not cxx_args: | ||
42 | + cxx_args = "-g" | ||
43 | + | ||
44 | + cpp_test = subprocess.Popen([cxx, cxx_args, '-x', 'c++', '-std=c++14', '-'], | ||
45 | stdin=PIPE, | ||
46 | stdout=PIPE, | ||
47 | stderr=PIPE) | ||
48 | @@ -216,8 +219,8 @@ def check_linker_need_libatomic(): | ||
49 | return False | ||
50 | # Double-check to see if -latomic actually can solve the problem. | ||
51 | # https://github.com/grpc/grpc/issues/22491 | ||
52 | - cpp_test = subprocess.Popen(cxx + | ||
53 | - ['-x', 'c++', '-std=c++14', '-', '-latomic'], | ||
54 | + cpp_test = subprocess.Popen( | ||
55 | + [cxx, cxx_args, '-x', 'c++', '-std=c++14', '-', '-latomic'], | ||
56 | stdin=PIPE, | ||
57 | stdout=PIPE, | ||
58 | stderr=PIPE) | ||
59 | --- a/src/python/grpcio/commands.py | ||
60 | +++ b/src/python/grpcio/commands.py | ||
61 | @@ -228,8 +228,10 @@ class BuildExt(build_ext.build_ext): | ||
62 | """ | ||
63 | try: | ||
64 | # TODO(lidiz) Remove the generated a.out for success tests. | ||
65 | - cc = os.environ.get('CC', 'cc') | ||
66 | - cc_test = subprocess.Popen([cc, '-x', 'c', '-std=c++14', '-'], | ||
67 | + cc_test, cc_args = os.environ.get('CC').split(' ', 1) or 'gcc' | ||
68 | + if not cc_args: | ||
69 | + cc_args = "-g" | ||
70 | + cc_test = subprocess.Popen([cc_test, cc_args, '-x', 'c', '-std=c++14', '-'], | ||
71 | stdin=subprocess.PIPE, | ||
72 | stdout=subprocess.PIPE, | ||
73 | stderr=subprocess.PIPE) | ||