diff options
author | Leon Anavi <leon.anavi@konsulko.com> | 2021-03-30 14:10:06 +0300 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-04-01 08:31:16 -0700 |
commit | f95812d0bc1bf25778566a44791257e5a113ab63 (patch) | |
tree | 837df8145b2cd8a3050d5a1f899102e82a3d9875 /meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch | |
parent | 8f3ee91cfc0d6478ce9764d3415111a08b5c522f (diff) | |
download | meta-openembedded-f95812d0bc1bf25778566a44791257e5a113ab63.tar.gz |
python3-h5py: Upgrade 3.1.0 -> 3.2.1
Upgrade to release 3.2.1:
- Added support to use the HDF5 ROS3 driver to access HDF5 files
on S3
- Setting the config option default_file_mode to values other than
'r' is deprecated. Pass the desired mode when opening a
:class:`~.File` instead.
- :exc:`OSError` exceptions raised by h5py should now have a useful
.errno attribute, where HDF5 provides this information.
Subclasses such as :exc:`FileNotFoundError` should also be raised
where appropriate.
- Fix reading data with a datatype of variable-length arrays of
fixed length strings.
- Fix :meth:`.Dataset.read_direct` and :meth:`.Dataset.write_direct`
when the source and destination have different shapes.
- Fix selecting data using integer indices in
:meth:`.Dataset.read_direct` and :meth:`.Dataset.write_direct`.
- Fix exception handling in :meth:`.Group.visititems`.
- Issue a warning when File(..., swmr=True) is specified with any
mode other than 'r', as the SWMR option is ignored in these cases.
- Fix NumPy 1.20 deprecation warnings concerning the use of None as
shape, and the deprecated aliases np.float, np.int and np.bool.
- Fix :attr:`.File.driver` when the read-only S3 driver is
available.
Add hdf5-native as a dependency to avoid:
error: libhdf5.so: cannot open shared object file: No such file or directory
Signed-off-by: Leon Anavi <leon.anavi@konsulko.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch | 8 |
1 files changed, 4 insertions, 4 deletions
diff --git a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch index 4881b023c8..9b79cc5395 100644 --- a/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch +++ b/meta-python/recipes-devtools/python/python3-h5py/0001-setup.py-Fix-numpy-version.patch | |||
@@ -1,4 +1,4 @@ | |||
1 | From e6c0d487fb5e6063305b8b3187896fbfe5720ed2 Mon Sep 17 00:00:00 2001 | 1 | From b1d4d171fd13624f3d8bb917f716b62494066501 Mon Sep 17 00:00:00 2001 |
2 | From: Leon Anavi <leon.anavi@konsulko.com> | 2 | From: Leon Anavi <leon.anavi@konsulko.com> |
3 | Date: Mon, 22 Feb 2021 18:42:43 +0200 | 3 | Date: Mon, 22 Feb 2021 18:42:43 +0200 |
4 | Subject: [PATCH] setup.py: Fix numpy version | 4 | Subject: [PATCH] setup.py: Fix numpy version |
@@ -14,12 +14,12 @@ Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> | |||
14 | 1 file changed, 1 insertion(+), 1 deletion(-) | 14 | 1 file changed, 1 insertion(+), 1 deletion(-) |
15 | 15 | ||
16 | diff --git a/setup.py b/setup.py | 16 | diff --git a/setup.py b/setup.py |
17 | index 7dbe583..6602c97 100755 | 17 | index 4b2890c..42ba21b 100755 |
18 | --- a/setup.py | 18 | --- a/setup.py |
19 | +++ b/setup.py | 19 | +++ b/setup.py |
20 | @@ -49,7 +49,7 @@ SETUP_REQUIRES = [ | 20 | @@ -49,7 +49,7 @@ SETUP_REQUIRES = [ |
21 | f"Cython >=0.29; python_version<'3.8'", | 21 | "Cython >=0.29.14; python_version=='3.8'", |
22 | f"Cython >=0.29.14; python_version>='3.8'", | 22 | "Cython >=0.29.15; python_version>='3.9'", |
23 | ] + [ | 23 | ] + [ |
24 | - f"numpy =={np_min}; python_version{py_condition}" | 24 | - f"numpy =={np_min}; python_version{py_condition}" |
25 | + f"numpy >={np_min}; python_version{py_condition}" | 25 | + f"numpy >={np_min}; python_version{py_condition}" |