summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb
diff options
context:
space:
mode:
authorLeon Anavi <leon.anavi@konsulko.com>2020-06-12 17:41:58 +0300
committerKhem Raj <raj.khem@gmail.com>2020-06-13 21:34:21 -0700
commit92abb5fac10144032f37d90c98fd5ee37ea51a83 (patch)
tree67ab731c2b4624b7ea6e4d535e378e5e3173fe22 /meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb
parent0ca82b3fc7634fa9d891ffdcf256a7d56793cdac (diff)
downloadmeta-openembedded-92abb5fac10144032f37d90c98fd5ee37ea51a83.tar.gz
python3-jsonpointer: Consolidate in a single file
Consolidate inc and bb files into a single bb file. Signed-off-by: Leon Anavi <leon.anavi@konsulko.com> Acked-by: Trevor Gamblin <trevor.gamblin@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb')
-rw-r--r--meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb29
1 files changed, 27 insertions, 2 deletions
diff --git a/meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb b/meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb
index 8d0a09b432..68bfe97166 100644
--- a/meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb
+++ b/meta-python/recipes-devtools/python/python3-jsonpointer_2.0.bb
@@ -1,2 +1,27 @@
1inherit setuptools3 1SUMMARY = "Resolve JSON Pointers in Python"
2require python-jsonpointer.inc 2HOMEPAGE = "https://github.com/stefankoegl/python-json-pointer"
3LICENSE = "BSD-3-Clause"
4LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=32b15c843b7a329130f4e266a281ebb3"
5
6inherit pypi ptest setuptools3
7
8SRC_URI[md5sum] = "741b98d0e693b08b5e44e0a9da5a7bb7"
9SRC_URI[sha256sum] = "c192ba86648e05fdae4f08a17ec25180a9aef5008d973407b581798a83975362"
10
11RDEPENDS_${PN} += " \
12 ${PYTHON_PN}-json \
13"
14
15BBCLASSEXTEND = "native nativesdk"
16
17SRC_URI += " \
18 file://run-ptest \
19"
20
21RDEPENDS_${PN}-ptest += " \
22 ${PYTHON_PN}-pytest \
23"
24
25do_install_ptest() {
26 cp -f ${S}/tests.py ${D}${PTEST_PATH}/
27}