diff options
author | William Huang <whuang8933@gmail.com> | 2021-09-02 07:25:07 -0400 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2021-09-03 08:35:28 -0700 |
commit | b1800419769236f7c449630a9fb398e084e81e47 (patch) | |
tree | 05bbe3711d4c3d413f8466fdbe489cedb3c76b57 /meta-python/recipes-devtools/python/python3-kivy | |
parent | 2ff8168c649b93e1d13fca5b2d563adc412c1571 (diff) | |
download | meta-openembedded-b1800419769236f7c449630a9fb398e084e81e47.tar.gz |
recipes-devtools: python: add support for Kivy
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Signed-off-by: Trevor Gamblin <trevor.gamblin@windriver.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-kivy')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | 24 |
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch new file mode 100644 index 0000000000..e50c7e7e24 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-kivy/0001-add-support-for-glesv2.patch | |||
@@ -0,0 +1,24 @@ | |||
1 | diff --git a/setup.py b/setup.py | ||
2 | index 9a507c6c4..3f5b70866 100644 | ||
3 | --- a/setup.py | ||
4 | +++ b/setup.py | ||
5 | @@ -680,7 +680,18 @@ def determine_gl_flags(): | ||
6 | c_options['use_x11'] = True | ||
7 | c_options['use_egl'] = True | ||
8 | else: | ||
9 | - flags['libraries'] = ['GL'] | ||
10 | + if cross_sysroot: | ||
11 | + flags['include_dirs'] = [cross_sysroot + '/usr/include'] | ||
12 | + flags['library_dirs'] = [cross_sysroot + '/usr/lib'] | ||
13 | + | ||
14 | + if c_options['use_opengl_es2']: | ||
15 | + print("using GLESv2 libraries") | ||
16 | + flags['libraries'] = ['GLESv2'] | ||
17 | + else: | ||
18 | + flags['libraries'] = ['GL'] | ||
19 | + | ||
20 | + | ||
21 | + print("cross_sysroot: " + str(cross_sysroot)) | ||
22 | return flags, base_flags | ||
23 | |||
24 | |||