diff options
author | Wang Mingyu <wangmy@fujitsu.com> | 2023-01-11 13:24:03 +0800 |
---|---|---|
committer | Khem Raj <raj.khem@gmail.com> | 2023-01-11 08:37:58 -0800 |
commit | 2721e7c7697fcce39bafdcbb295e7152e85b83a2 (patch) | |
tree | e25252932802deade18ec7ba35c4700f6b251461 /meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb | |
parent | 0a069201a84e83b98da9e38bca5a74179b28336e (diff) | |
download | meta-openembedded-2721e7c7697fcce39bafdcbb295e7152e85b83a2.tar.gz |
python3-lazy-object-proxy: upgrade 1.8.0 -> 1.9.0
License-Update: Copyright year updated to 2023.
Changelog:
==========
- Added support for matrix multiplication operator (@).
- Should have all the wheels now (including the manylinux ones).
- Bumped minimum version requirements for setuptools and setuptools-scm.
- Switched the default pure python fallback implementation to the "simple" one
(when you from lazy_object_proxy import Proxy and the C extension is not
available). Previously the "slots" implementation was used but as it turns
out it is slower on Python 3.
Signed-off-by: Wang Mingyu <wangmy@fujitsu.com>
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb')
-rw-r--r-- | meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb | 11 |
1 files changed, 11 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb b/meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb new file mode 100644 index 0000000000..74c5e9b520 --- /dev/null +++ b/meta-python/recipes-devtools/python/python3-lazy-object-proxy_1.9.0.bb | |||
@@ -0,0 +1,11 @@ | |||
1 | SUMMARY = "A fast and thorough lazy object proxy" | ||
2 | HOMEPAGE = "https://python-lazy-object-proxy.readthedocs.io/" | ||
3 | LICENSE = "BSD-2-Clause" | ||
4 | SECTION = "devel/python" | ||
5 | LIC_FILES_CHKSUM = "file://LICENSE;md5=d606e94f56c21c8e0cdde0b622dcdf57" | ||
6 | |||
7 | DEPENDS += "${PYTHON_PN}-setuptools-scm-native ${PYTHON_PN}-pip-native" | ||
8 | |||
9 | SRC_URI[sha256sum] = "659fb5809fa4629b8a1ac5106f669cfc7bef26fbb389dda53b3e010d1ac4ebae" | ||
10 | |||
11 | inherit pypi setuptools3 | ||