summaryrefslogtreecommitdiffstats
path: root/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
diff options
context:
space:
mode:
authorMingli Yu <mingli.yu@windriver.com>2025-03-28 13:11:24 +0800
committerKhem Raj <raj.khem@gmail.com>2025-03-28 10:28:12 -0700
commit5b010f6358f18bcf05823a5cf30b0b22ac45d377 (patch)
tree59ccbbc8dba87e4a8fe60a1f888cfb05dbad9625 /meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
parent4541a50c56544a4abb28fae7dbb3ad2114870d3f (diff)
downloadmeta-openembedded-5b010f6358f18bcf05823a5cf30b0b22ac45d377.tar.gz
python3-m2crypto: Upgrade 0.42.0 -> 0.44.0
Changelog: https://gitlab.com/m2crypto/m2crypto/-/tags The cmd will be None after introduced the commit [1] in the new version and result the below do_compile error. DEBUG: Executing shell function do_compile * Getting build dependencies for wheel... [snip] TypeError: expected str, bytes or os.PathLike object, not NoneType ERROR Backend subprocess exited when trying to invoke get_requires_for_build_wheel So make the cmd available to fix the above issue. [1] https://gitlab.com/m2crypto/m2crypto/-/commit/4d7880b019a67e24458b1c9a50331c18c9eec827 Signed-off-by: Mingli Yu <mingli.yu@windriver.com> Signed-off-by: Khem Raj <raj.khem@gmail.com>
Diffstat (limited to 'meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch')
-rw-r--r--meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
new file mode 100644
index 0000000000..819ecabf6c
--- /dev/null
+++ b/meta-python/recipes-devtools/python/python3-m2crypto/0001-setup.py-Make-the-cmd-available.patch
@@ -0,0 +1,40 @@
1From b14664fdab286485c5cbc0fbe5b0ff13f062edd8 Mon Sep 17 00:00:00 2001
2From: Mingli Yu <mingli.yu@windriver.com>
3Date: Fri, 28 Mar 2025 12:13:26 +0800
4Subject: [PATCH] setup.py: Make the cmd available
5
6The cmd will be None in OE environment as below.
7 >>> import os
8 >>> os.environ.get('CC', 'gcc')
9'x86_64-wrs-linux-gcc -m64 -march=nehalem -mtune=generic -mfpmath=sse -msse4.2 -fstack-protector-strong -O2 -D_FORTIFY_SOURCE=2 -Wformat -Wformat-security -Werror=format-security --sysroot=/buildarea/tmp/work/corei7-64-wrs-linux/python3-m2crypto/0.44.0/recipe-sysroot'
10 >>> import shutil
11 >>> shutil.which(os.environ.get('CC', 'gcc'))
12 >>> cmd = [shutil.which(os.environ.get('CC', 'gcc'))]
13 >>> print(cmd)
14[None]
15
16So change the check logic to get the expected cmd.
17
18Upstream-Status: Inappropriate [oe specific]
19
20Signed-off-by: Mingli Yu <mingli.yu@windriver.com>
21---
22 setup.py | 2 +-
23 1 file changed, 1 insertion(+), 1 deletion(-)
24
25diff --git a/setup.py b/setup.py
26index 7e295f3..cc414c9 100644
27--- a/setup.py
28+++ b/setup.py
29@@ -221,7 +221,7 @@ class _M2CryptoBuildExt(build_ext.build_ext):
30 with open(
31 "src/SWIG/x509_v_flag.h", "w", encoding="utf-8"
32 ) as x509_v_h:
33- cmd = [shutil.which(os.environ.get('CC', 'gcc'))]
34+ cmd = os.environ.get('CC', 'gcc').split()
35 cflags = os.environ.get("CFLAGS")
36 if cflags is not None:
37 cmd += cflags.split()
38--
392.34.1
40